geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chi runhua <chirun...@gmail.com>
Subject Re: Could not build Geronimo server from SVN branch 2.2
Date Wed, 11 Nov 2009 02:58:52 GMT
I update the page on GMOxDEV based on this discussion, anything incorrect,
please let me know.

http://cwiki.apache.org/GMOxDEV/building-apache-geronimo.html

Jeff

On Wed, Nov 11, 2009 at 5:47 AM, Joe Bohn <joe.bohn@earthlink.net> wrote:

>  Kevan Miller wrote:
>
>>
>> On Nov 10, 2009, at 3:31 PM, Joe Bohn wrote:
>>
>> After looking into this some more and discussing it off-line with Jarek
>>> I've learned the following:
>>>
>>> - It isn't really returning a bogus pom or jar ... it is just returning a
>>> redirect.  Maven wrongly assumes that this is the actual file that was
>>> requested and persists it as such.
>>> - Using Maven 2.2.1 (I was using 2.0.10) doesn't handle the redirects any
>>> better and so doesn't fix the problem.
>>> - For tags/2.1.4 maven 2.2.1 also causes other problems so it's best to
>>> stick with maven 2.1.10 of you are building Geronimo 2.1.*
>>> - org/apache/yoko/yoko/1.0/yoko-1.0.pom includes a repository list that
>>> points to https://maven-repository.dev.java.net/nonav/repositorid of
>>> java.net so this is why we are pulling in that repo
>>> - If I add the following to my settings.xml for maven I can avoid the
>>> redirect (and hence avoid the bogus poms/jars) and get beyond this problem
>>> to build Geronimo 2.1.4 using maven 2.0.10.
>>>
>>>   <mirrors>
>>>       <mirror>
>>>           <id>java.net</id>
>>>           <name>Mirror of
>>> https://maven-repository.dev.java.net/nonav/repository/</name>
>>>           <url>http://download.java.net/maven/1/</url>
>>>           <mirrorOf>java.net</mirrorOf>
>>>       </mirror>
>>>   </mirrors>
>>>
>>
>> Thanks Joe! I tried a mirror setting, but must not have gotten the mirror
>> setting correct...
>>
>> --kevan
>>
>>
> I think they key is that the <mirrorOf> value in your mirror must match the
> <id> that is used in the original reference to the repository.  In the case
> of 2.1.4 it was pulling in yoko which had a parent pom with the following
> repository entry:
>
>        <repository>
>            <id>java.net</id>
>            <name>java.net Maven Repository</name>
>
> <url>https://maven-repository.dev.java.net/nonav/repository/</url>
>            <layout>legacy</layout>
>        </repository>
>
> So when I created my mirror in settings.xml I included "java.net" in my
> <mirrorOf> value.  I also included the same value in the <id> of my mirror
> but I don't think that is necessary.
>
> Joe
>
>
>

Mime
View raw message