geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashish Jain (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-4844) There is an error after undeploy the application and deploy the application again when configure WADI clustering,
Date Thu, 26 Nov 2009 14:25:39 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-4844?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12782907#action_12782907
] 

Ashish Jain commented on GERONIMO-4844:
---------------------------------------

It seems the gbean is still in the running state after undeployment. The inforegistry has
an entry for the application which suggests the gbean is in the running state
even after undeployment. That is the reason Deployer.getConfigID returns an exception suggesting
Module already exists. I will investigate more and will try to provide
a patch for this issue.

> There is an error after undeploy the application and  deploy the application again when
configure WADI clustering,
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-4844
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4844
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: Clustering
>    Affects Versions: 2.1.4
>         Environment: windows:sp2
> jdk1.6
>            Reporter: liangkun
>            Assignee: Shawn Jiang
>
> I deploy the application cviewer.war after undeploy it when configure the WADI clustering
,the there is an error:
> org.apache.geronimo.common.DeploymentException: Unable to deploy cviewer-2.1.1.2.war:
Module com.ibm.wasce.samples/cviewer/2.1.1.2/car already exists in the server.  Try to undeploy
it first or use the redeploy command.
> 	at org.apache.geronimo.deployment.cli.CommandDeploy.runCommand(CommandDeploy.java:45)
> 	at org.apache.geronimo.deployment.cli.CommandDistribute.executeOnline(CommandDistribute.java:139)
> 	at org.apache.geronimo.deployment.cli.CommandDistribute.execute(CommandDistribute.java:125)
> 	at org.apache.geronimo.deployment.cli.DeployTool.execute(DeployTool.java:168)
> 	at org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(MainConfigurationBootstrapper.java:45)
> 	at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:65)
> 	at org.apache.geronimo.cli.deployer.DeployerCLI.main(DeployerCLI.java:31)
> However,actually,there are no any module in the server.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message