geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: Could not build Geronimo server from SVN branch 2.2
Date Tue, 10 Nov 2009 20:31:20 GMT
After looking into this some more and discussing it off-line with Jarek 
I've learned the following:

- It isn't really returning a bogus pom or jar ... it is just returning 
a redirect.  Maven wrongly assumes that this is the actual file that was 
requested and persists it as such.
- Using Maven 2.2.1 (I was using 2.0.10) doesn't handle the redirects 
any better and so doesn't fix the problem.
- For tags/2.1.4 maven 2.2.1 also causes other problems so it's best to 
stick with maven 2.1.10 of you are building Geronimo 2.1.*
- org/apache/yoko/yoko/1.0/yoko-1.0.pom includes a repository list that 
points to https://maven-repository.dev.java.net/nonav/repositorid of 
java.net so this is why we are pulling in that repo
- If I add the following to my settings.xml for maven I can avoid the 
redirect (and hence avoid the bogus poms/jars) and get beyond this 
problem to build Geronimo 2.1.4 using maven 2.0.10.

     <mirrors>
         <mirror>
             <id>java.net</id>
             <name>Mirror of 
https://maven-repository.dev.java.net/nonav/repository/</name>
             <url>http://download.java.net/maven/1/</url>
             <mirrorOf>java.net</mirrorOf>
         </mirror>
     </mirrors>


Joe

Joe Bohn wrote:
> It really concerns me that we can't even build 2.1.4 from the tag.  I 
> went out there and attempted this and received the same bogus pom for 
> several artifacts including:
> 
> org/apache/yoko/yoko-rmi-spec/1.0/yoko-rmi-spec-1.0.pom
> and
> log4j/log4j/1.2.13/log4j-1.2.13.pom
> 
> 
> I was speaking with Kevan and it seems that some other project must 
> include this maven-repository.dev.java.net and is attempting to pull 
> some common dependencies from it (like log4j and yoko).  Instead of 
> returning a failure the repo is returning this bogus pom.  So it seems 
> that 2 things need to happen:
> 
> 1) What ever project that is (need to find it) - it needs to update to 
> the new repository.
> 2) A failure should be returned from the old repo rather than these 
> bogus poms.
> 
> 
> Joe
> 
> 
> 
> Jay D. McHugh wrote:
>> Here is what they problem is - they moved that artifact.
>>
>> In its place is the following html file (rather than a pom)
>>
>> <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
>> <html><head>
>> <title>301 Moved Permanently</title>
>> </head><body>
>> <h1>Moved Permanently</h1>
>> <p>The document has moved <a
>> href="http://download.java.net/maven/1/com.envoisolutions.sxc/poms/sxc-runtime-0.7.2.pom">here</a>.</p>

>>
>> <hr>
>> <address>Apache Server at maven-repository.dev.java.net Port 
>> 443</address>
>> </body></html>
>>
>> So that is why it isn't working anymore.
>>
>> Jay
>>
>> Jay D. McHugh wrote:
>>> Hello,
>>>
>>> It looks like the automated build has been failing since 11/7 on that
>>> artifact (com.envoisolutions.sxc).
>>>
>>> So - I think that it has somehow become corrupted in the maven
>>> repositories.  If anyone had a local version that was 'good', then they
>>> would be able to build 2.2.
>>>
>>> If they were starting from scratch (like yourself) or cleared their
>>> local repo - then they would start getting errors.
>>>
>>> We will try to see if we can find a good copy of the artifacts (or to
>>> have a good copy reloaded into the repos).
>>>
>>> Sorry for the trouble.  Hopefully, we will be able to get things
>>> straightened out soon (for you and us as well).
>>>
>>> Jay
>>>
>>> Fei LI wrote:
>>>> Hi,
>>>>
>>>> Another failed day to build Geronimo server from SVN branch 2.2.
>>>>
>>>> My OS is Windows XP.
>>>>
>>>> Today I tried:
>>>> Jsdk 1.6.0_16
>>>> Jsdk 1.5.0_22
>>>> Maven 2.2.1
>>>> Maven 2.0.10
>>>>
>>>> Donald woods helped me to try shorter folder like c:\g22; c:\m2repo, 
>>>> did
>>>> not work.
>>>> He also asked me to delete some troubled files and did not work too.
>>>>
>>>> So far, I tried 2.1.4, 2.2 and trunk and no one works.
>>>>
>>>>
>>>> Anybody ever clean your repo and build from nothing just kie me? Try!
>>>> Please!!! Tell me how to build then.
>>>>
>>>>
>>>> Thanks
>>>>
>>>> Fei Li
>>>>
>>>> See my error:
>>>>
>>>> [INFO] [enforcer:enforce {execution: default}]
>>>> [WARNING] POM for 
>>>> 'com.envoisolutions.sxc:sxc-runtime:pom:0.7.2:compile'
>>>> is invalid. It will be ignored for artifact resolution. Reason: Not a
>>>> v4.0.0 POM. for p
>>>>
>>>> roject com.envoisolutions.sxc:sxc-runtime at
>>>> C:\m2repo\com\envoisolutions\sxc\sxc-runtime\0.7.2\sxc-runtime-0.7.2.pom

>>>>
>>>> [WARNING] POM for 
>>>> 'com.envoisolutions.sxc:sxc-runtime:pom:0.7.2:compile'
>>>> is invalid. It will be ignored for artifact resolution. Reason: Not a
>>>> v4.0.0 POM. for p
>>>>
>>>> roject com.envoisolutions.sxc:sxc-runtime at
>>>> C:\m2repo\com\envoisolutions\sxc\sxc-runtime\0.7.2\sxc-runtime-0.7.2.pom

>>>>
>>>> [INFO] [plugin:descriptor]
>>>> [INFO] Using 'UTF-8' encoding to read mojo metadata.
>>>> [INFO] Applying mojo extractor for language: java
>>>> [WARNING] 
>>>> org.apache.geronimo.mavenplugins.car.ArchiveCarMojo#jarArchiver:
>>>> [WARNING]   The syntax
>>>> [WARNING]     @parameter expression="${component.<role>#<roleHint>}"
>>>> [WARNING]   is deprecated, please use
>>>> [WARNING]     @component role="<role>" roleHint="<roleHint>"
>>>> [WARNING]   instead.
>>>> [INFO] Mojo extractor for language: java found 10 mojo descriptors.
>>>> [INFO] Applying mojo extractor for language: bsh
>>>> [INFO] Mojo extractor for language: bsh found 0 mojo descriptors.
>>>> [WARNING] POM for 
>>>> 'com.envoisolutions.sxc:sxc-runtime:pom:0.7.2:compile'
>>>> is invalid. It will be ignored for artifact resolution. Reason: Not a
>>>> v4.0.0 POM. for p
>>>>
>>>> roject com.envoisolutions.sxc:sxc-runtime at
>>>> C:\m2repo\com\envoisolutions\sxc\sxc-runtime\0.7.2\sxc-runtime-0.7.2.pom

>>>>
>>>> [WARNING] POM for 
>>>> 'com.envoisolutions.sxc:sxc-runtime:pom:0.7.2:compile'
>>>> is invalid. It will be ignored for artifact resolution. Reason: Not a
>>>> v4.0.0 POM. for p
>>>>
>>>> roject com.envoisolutions.sxc:sxc-runtime at
>>>> C:\m2repo\com\envoisolutions\sxc\sxc-runtime\0.7.2\sxc-runtime-0.7.2.pom

>>>>
>>>> [INFO] [remote-resources:process {execution: default}]
>>>> [WARNING] Attempting to build MavenProject instance for Artifact
>>>> (com.envoisolutions.sxc:sxc-runtime:0.7.2) of type: jar; constructing
>>>> POM artifact instead.
>>>>
>>>> [WARNING] Invalid project model for artifact
>>>> [sxc-runtime:com.envoisolutions.sxc:0.7.2]. It will be ignored by the
>>>> remote resources Mojo.
>>>>
>>>> [INFO] [resources:resources]
>>>> [INFO] Using 'UTF-8' encoding to copy filtered resources.
>>>> [INFO] Copying 1 resource
>>>> [INFO] skip non existing resourceDirectory
>>>> C:\g22\framework\buildsupport\car-maven-plugin\src\main\filtered-resources

>>>>
>>>> [INFO] Copying 3 resources
>>>> [WARNING] POM for 
>>>> 'com.envoisolutions.sxc:sxc-runtime:pom:0.7.2:compile'
>>>> is invalid. It will be ignored for artifact resolution. Reason: Not a
>>>> v4.0.0 POM. for p
>>>>
>>>> roject com.envoisolutions.sxc:sxc-runtime at
>>>> C:\m2repo\com\envoisolutions\sxc\sxc-runtime\0.7.2\sxc-runtime-0.7.2.pom

>>>>
>>>> [WARNING] POM for 
>>>> 'com.envoisolutions.sxc:sxc-runtime:pom:0.7.2:compile'
>>>> is invalid. It will be ignored for artifact resolution. Reason: Not a
>>>> v4.0.0 POM. for p
>>>>
>>>> roject com.envoisolutions.sxc:sxc-runtime at
>>>> C:\m2repo\com\envoisolutions\sxc\sxc-runtime\0.7.2\sxc-runtime-0.7.2.pom

>>>>
>>>> [INFO] [compiler:compile]
>>>> [INFO] Compiling 20 source files to
>>>> C:\g22\framework\buildsupport\car-maven-plugin\target\classes
>>>> [INFO]
>>>> ------------------------------------------------------------------------

>>>>
>>>> [ERROR] BUILD FAILURE
>>>> [INFO]
>>>> ------------------------------------------------------------------------

>>>>
>>>> [INFO] Compilation failure
>>>> error: error reading
>>>> C:\m2repo\com\envoisolutions\sxc\sxc-runtime\0.7.2\sxc-runtime-0.7.2.jar;

>>>>
>>>> error in opening zip file
>>>>
>>>>
>>>> error: error reading
>>>> C:\m2repo\com\envoisolutions\sxc\sxc-runtime\0.7.2\sxc-runtime-0.7.2.jar;

>>>>
>>>> error in opening zip file
>>>>
>>>>
>>
> 
> 


Mime
View raw message