geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <dwo...@apache.org>
Subject Re: help
Date Wed, 04 Nov 2009 20:37:00 GMT
As mentioned in the other email, you want the Server 2.2 branch -
    https://svn.apache.org/repos/asf/geronimo/server/branches/2.2

Server trunk is undergoing major changes to OSGi right now and GEP trunk 
(2.2.0) has to be built against a 2.2 server....


-Donald


Fei LI wrote:
> Hi Donald,
> 
> Thanks for your answer and I tried to build the server first, and I got
> error message:
> "
> [INFO] Unable to find resource
> 'org.apache.geronimo.bundles:commons-cli:jar:1.0_1-SNAPSHOT' in
> repository apache.snapshots (http://repository.apache.org/snapshots)
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> 
> Missing:
> ----------
> 1) org.apache.geronimo.bundles:commons-cli:jar:1.0_1-SNAPSHOT
> "
> 
> 
> My building environment is:
> Windows XP
> apache-maven-2.2.0
> Source code from: https://svn.apache.org/repos/asf/geronimo/server/trunk
> 
> 
> 
> Any suggestion?
> 
> Thanks
> 
> Fei Li
> 
> 
>  
> 
> -----Original Message-----
> From: Donald Woods [mailto:dwoods@apache.org] 
> Sent: Wednesday, November 04, 2009 11:25 AM
> To: dev@geronimo.apache.org
> Cc: Fei LI
> Subject: Re: help
> 
> Please post the exact build errors you are seeing.
> 
> Also, most GEP developers build the latest 2.2 server before trying to
> build GEP, so you'll have all of the required depends already installed
> in your local m2 repo.....
> 
> 
> -Donald
> 
> 
> Fei LI wrote:
>> Hi,
>>
>> I am 100% new.
>>
>> I could not find help anywhere. Anybody can tell me where is my help?
>>
>> Thanks first.
>>
>> I want to learn geronimo and do some develop for it if possible. I 
>> followed the instruction from apache-geronimo page "How to Build 
>> Geronimo Eclipse Plugin from Source"
>>
>> 1. installed Apache Maven 2.0.9
>> 2.get source code from
>> _http://svn.apache.org/repos/asf/geronimo/devtools/eclipse-plugin/trun
>> k_ 3. set MAVEN_OPTS=-Xmx512m -XX:MaxPermSize=128m 3. run command mvn 
>> clean install -Ptestsuite.
>>
>> I always got error, missing something or run test error.
>>
>> Thanks
>>
>> Fei Li
>>
>>
> 

Mime
View raw message