geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Quintin Beukes (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-4871) Something blocking 'kill -3' signals?
Date Tue, 27 Oct 2009 17:00:59 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-4871?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12770567#action_12770567
] 

Quintin Beukes commented on GERONIMO-4871:
------------------------------------------

It has to be something that changed between that 2. I'm sure that part is obvious for anyone
reading this.

It has to also be something the 2 does different. Perhaps related to a JavaAgent or JMX? Something
else that captures the signal? 

Have you tried echoing the command geronimo.sh uses to start and then running it manually,
removing arguments until you find on that could possibly trigger this? Does the same happen
when you run the minimal server? Have you tried to remove modules until you could perhaps
find one, which without it everything works?

If I had a Mac I would have a look at it, but ... :>

> Something blocking 'kill -3' signals?
> -------------------------------------
>
>                 Key: GERONIMO-4871
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4871
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>            Reporter: Kevan Miller
>             Fix For: 2.2.1
>
>
> I occasionally use 'kill -3' to cause a java process to dump all thread stacks. For some
reason, this isn't working on Geronimo 2.2

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message