There's a JIRA opened about the plugin installing: https://issues.apache.org/jira/browse/GERONIMO-4829.  It happens because the new 2.2-snapshot plugins can't be found in m2-snapshot-repository. >From my understanding,  current apache.snapshot is a proxy to

1, new nexus apache snapshot repo.
2, legacy m2-snapshot-repository

So that we should replace all m2-snapshot-repository to  https://repository.apache.org/snapshots.      Any thoughts ?

--
Shawn