geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-4834) artifact aliasing does not seem to work for configuration id's
Date Tue, 01 Sep 2009 19:56:32 GMT
artifact aliasing does not seem to work for configuration id's
--------------------------------------------------------------

                 Key: GERONIMO-4834
                 URL: https://issues.apache.org/jira/browse/GERONIMO-4834
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
          Components: core
    Affects Versions: 2.1.4
            Reporter: Vamsavardhana Reddy
             Fix For: 2.1.5, 2.2


Artifact aliasing does not seem to work for configuration ids.  I have encountered the following
problem while trying to change the JPA provider from OpenJPA to TopLink.
I have created a configuration o.a.g.configs/toplink/2.1.4/car to replace openjpa car.  I
have added the following line in artifact_aliases.properties:
org.apache.geronimo.configs/openjpa//car=org.apache.geronimo.configs/toplink/2.1.4/car

But when I start the server, openjpa//car is getting started as openejb//car has a dependency
on openjpa//car.  Ideally I would expect toplink//car to be used by openejb//car because of
the aliasing above.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message