geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shawn Jiang (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (GERONIMO-4829) can't install Geronimo Plugins, Monitoring :: Agent JMX CAR from http://geronimo.apache.org/plugins/geronimo-2.2/
Date Thu, 03 Sep 2009 06:39:32 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-4829?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12750831#action_12750831
] 

Shawn Jiang edited comment on GERONIMO-4829 at 9/2/09 11:38 PM:
----------------------------------------------------------------

Seems everything is working find now, please verify and close this JIRA, thanks.

      was (Author: genspring):
    After switching to the right snapshot repository.  there's still a problem.

The plugins install try to download 

{noformat}
http://repository.apache.org/snapshots/org/apache/geronimo/plugins/monitoring/agent-car-jmx/2.2-SNAPSHOT/agent-car-jmx-2.2-SNAPSHOT.car
{noformat}
from the apache.snapshot.  But there's only complex version package in the repo.  So that
the plugin installer can't download the car successfully.

{noformat}
http://repository.apache.org/snapshots/org/apache/geronimo/plugins/monitoring/agent-car-jmx/2.2-SNAPSHOT/agent-car-jmx-2.2-20090714.141451-2.car{noformat}

I'll try to simulate the maven snapshot downloading mechanism to resolve this issue.
  
> can't install Geronimo Plugins, Monitoring :: Agent JMX CAR  from http://geronimo.apache.org/plugins/geronimo-2.2/
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-4829
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4829
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: buildsystem
>    Affects Versions: 2.2
>         Environment: jdk6
> windows sp2
>            Reporter: Bin He
>            Assignee: Shawn Jiang
>            Priority: Blocker
>
> 1、start server
> 2、click  plugins porlet
> 3、choose "http://geronimo.apache.org/plugins/geronimo-2.2/"  ,and click "Show Plugins
in selected repository"
> 4、so the plugins listed at http://geronimo.apache.org/plugins/geronimo-2.2/ is present.And
choose "Geronimo Plugins, Monitoring :: Agent JMX CAR"  to install . 
> 5、But when I click" intall",it showd :(I think if this problem can't be solved,we can't
do the work related to jmx)
> Current file being operated on... 
> Downloading org.apache.geronimo.plugins.monitoring/agent-car-jmx/2.2-SNAPSHOT/car
> A problem has occured: 
> java.lang.IllegalArgumentException: Could not find org.apache.geronimo.plugins.monitoring/agent-car-jmx/2.2-SNAPSHOT/car
in any repo: [org.apache.geronimo.system.plugin.RemoteSourceRepository:http://geronimo.apache.org/plugins/geronimo-2.2/,
org.apache.geronimo.system.plugin.RemoteSourceRepository:http://repo1.maven.org/maven2/, org.apache.geronimo.system.plugin.RemoteSourceRepository:http://people.apache.org/repo/m2-snapshot-repository/,
org.apache.geronimo.system.plugin.RemoteSourceRepository:http://people.apache.org/repo/m2-incubating-repository/]

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message