geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Quintin Beukes (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-4858) Geronimo 2.2 doesn't ad
Date Wed, 09 Sep 2009 14:10:57 GMT
Geronimo 2.2 doesn't ad
-----------------------

                 Key: GERONIMO-4858
                 URL: https://issues.apache.org/jira/browse/GERONIMO-4858
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
          Components: connector, console
    Affects Versions: 2.2, 3.0
            Reporter: Quintin Beukes
            Priority: Critical
             Fix For: 2.2


OK. So I extract the 2009-09-08 nightly snapshot (tomcat binary), and deploy some repository
JARs, a datasource and a security realm. Then I goto Web Server portlet and create a new Tomcat
BIO connector. I enter a name, and for port I enter 80. This is a rough of the steps I took
from a clean install.

So the bug is that when you add a connector, it immediately starts it on the correct port
(as can be seen with netstat), but it saves to var/catalina/server.xml with port 8080. So
once you restart the server you receive a port conflict if you have another 8080, and if you
don't it would be like you never made the change, with your connector reverting to 8080.

Here is a snippet of what it saves after adding a port "801" BIO connector:
<Connector connectionTimeout="60000" executor="DefaultThreadPool" name="testConnector1"
port="8080" protocol="HTTP/1.1" redirectPort="8443" server=""/>

Q


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message