geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <>
Subject [jira] Closed: (GERONIMO-4780) jsr88 client is too dependent on too many plugins
Date Sat, 01 Aug 2009 20:44:14 GMT


David Jencks closed GERONIMO-4780.

    Resolution: Fixed

I think this is fixed in rev 799922.  Reopen if problems appear.

> jsr88 client is too dependent on too many plugins
> -------------------------------------------------
>                 Key: GERONIMO-4780
>                 URL:
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: deployment
>    Affects Versions: 2.2
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 2.2
>         Attachments: GERONIMO-4780-preliminary.patch
> We're seeing some problems with a jsr88 client that is running with a security manager.
 The jsr88 rar configurer plugin has a classes dependency on the connector-deployer plugin
to get its classes.  In the configuration in question, this involves loading but not starting
a gbean with an encrypted attribute, which loads JCE which requires permission to create (but
not install) a security manager.
> The other jsr88 plugins don't use a plugin dependency to get classes, but rather a jar
dependency.  I think this will work OK for the rar configurer also.  Also, its not like anyone
uses this stuff.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message