geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rodger Zhang (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMODEVTOOLS-589) If GEP2.2 needs to support Eclipse3.3
Date Thu, 27 Aug 2009 08:18:59 GMT
If GEP2.2 needs to support Eclipse3.3
-------------------------------------

                 Key: GERONIMODEVTOOLS-589
                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-589
             Project: Geronimo-Devtools
          Issue Type: Wish
          Components: eclipse-plugin
    Affects Versions: 2.2.0
         Environment: Eclipse3.3
            Reporter: Rodger Zhang
            Assignee: Tim McConnell


If GEP2.2 needs to support Eclipse3.3, there a a few codes required modifying.
2 compiling errors exists:
1. org.apache.geronimo.st.core.GeronimoLaunchConfigurationDelegate
...
if (configuration.hasAttribute(...))
...
There is no "hasAttribute()" method in previous version.

2. org.apache.geronimo.st.v21.ui.ServerPluginPage
...
setManagedForm(managedForm);
...
There is no "setManagedForm()" method in previous version.
===================================================================
For the first point, I have a solution as in patch. Please check if feasible.
For the second point, a discussion ? Please add comment.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message