geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-4784) Problem with ActiveMQ, two connections/sessions, and UserTransaction
Date Tue, 11 Aug 2009 17:18:15 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-4784?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12741969#action_12741969
] 

David Jencks commented on GERONIMO-4784:
----------------------------------------

The test is part of testsuite/enterprise-testsuite/jms-tests.

I've found a workaround but I think there is still an underlying problem.

To run the test:

in one console start a geronimo server
in another console cd testsuite/enterprise-testsuite/jms-tests
mvn clean install -Pstandalone

(the standalone profile starts the selenium server: this is not necessary if you edit the
testng.xml file as below)

To run only the failing test patch the testng.xml file:

Index: jms-ear/src/test/resources/testng.xml
===================================================================
--- jms-ear/src/test/resources/testng.xml       (revision 802438)
+++ jms-ear/src/test/resources/testng.xml       (working copy)
@@ -24,12 +24,12 @@
 
 <suite name="Suite1" verbose="1">
     <test name="enterprise-testsuite.jms">
-        <packages>
-            <package name="org.apache.geronimo.testsuite.enterprise.jms"/>
-        </packages>
+        <!--<packages>-->
+            <!--<package name="org.apache.geronimo.testsuite.enterprise.jms"/>-->
+        <!--</packages>-->
         <!-- reverse what is commented out to just run the GERONIMO-4784 failing test
-->
-        <!--<classes>-->
-            <!--<class name="org.apache.geronimo.testsuite.enterprise.jms.RollbackTest"/>-->
-        <!--</classes>-->
+        <classes>
+            <class name="org.apache.geronimo.testsuite.enterprise.jms.RollbackTest"/>
+        </classes>
     </test>
 </suite>


The workaround I've found that makes the pool use only one connection:

Index: jms-ear/src/main/filtered-resources/META-INF/geronimo-application.xml
===================================================================
--- jms-ear/src/main/filtered-resources/META-INF/geronimo-application.xml       (revision
802438)
+++ jms-ear/src/main/filtered-resources/META-INF/geronimo-application.xml       (working copy)
@@ -115,6 +115,7 @@
                             <connectionmanager>
                                 <xa-transaction>
                                     <transaction-caching/>
+                                    <thread-caching/>
                                 </xa-transaction>
                                 <single-pool>
                                     <max-size>20</max-size>

There seems to be a problem with undeploying apps that use mdbs: to avoid this so you can
run the test more than once without a fresh g. server each time:

Index: jms-ear/pom.xml
===================================================================
--- jms-ear/pom.xml     (revision 802438)
+++ jms-ear/pom.xml     (working copy)
@@ -153,16 +153,16 @@
                         </configuration>
                     </execution>
 
-                    <execution>
-                        <id>undeploy</id>
-                        <phase>post-integration-test</phase>
-                        <goals>
-                            <goal>undeploy-module</goal>
-                        </goals>
-                        <configuration>
-                            <moduleId>${groupId}/${artifactId}/${version}/ear</moduleId>
-                        </configuration>
-                    </execution>
+                    <!--<execution>-->
+                        <!--<id>undeploy</id>-->
+                        <!--<phase>post-integration-test</phase>-->
+                        <!--<goals>-->
+                            <!--<goal>undeploy-module</goal>-->
+                        <!--</goals>-->
+                        <!--<configuration>-->
+                            <!--<moduleId>${groupId}/${artifactId}/${version}/ear</moduleId>-->
+                        <!--</configuration>-->
+                    <!--</execution>-->
                 </executions>
             </plugin>
         </plugins>




> Problem with ActiveMQ, two connections/sessions, and UserTransaction
> --------------------------------------------------------------------
>
>                 Key: GERONIMO-4784
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4784
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: ActiveMQ
>    Affects Versions: 2.2
>            Reporter: David Jencks
>             Fix For: 2.2
>
>
> This is probably a problem in activemq with dealing with multiple connection handles
to the same managed connection and XA transactions controlled by UserTransaction.  It may
be causing intermittent tck failures.  In any case I think the test ought to work.
> Not sure how to reproduce this in AMQ standalone yet, so I'm adding a testsuite test
to demonstrate the problem.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message