geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Jiang <genspr...@gmail.com>
Subject Re: Trunk Builds
Date Tue, 07 Jul 2009 07:38:08 GMT
Sorry, Are we using the same trunk build ? I downloaded the tomcat trunk
build here:

*
http://people.apache.org/builds/geronimo/server/binaries/trunk/20090703/geronimo-tomcat6-javaee5-2.2-SNAPSHOT-bin.zip
*

When accessing  http://localhost:8080/*dojo/dojo/*dojo.js ,  I got it's
content:

/*
	Copyright (c) 2004-2008, The Dojo Foundation All Rights Reserved.
	Available via Academic Free License >= 2.1 OR the modified BSD license.
	see: http://dojotoolkit.org/license for details
*/

(function(){var _1=null;if((_1||(typeof
djConfig!="undefined"&&djConfig.scopeMap))&&(typeo


When accessing http://localhost:8080/*dojo/dojo/dojo*/dojo.js, I got this:
HTTP Status 404
I also tried to revert ConfirmMessageTag.java to dojo/dojo/dojo.js from
dojo/dojo/dojo/dojo.js.   The dialog poped up and the test suite passed.
So , can anyone else help verify this ?

On Tue, Jul 7, 2009 at 1:09 AM, Jarek Gawor <jgawor@gmail.com> wrote:

> Shawn,
>
> I recently modified ConfirmMessageTag.java so that it points to the
> right locations for dojo resources. It used to point to
> http://localhost:8080/dojo/dojo/dojo.js (which does not work) but now
> points to http://localhost:8080/dojo/dojo/dojo/dojo.js (which does
> work). That made the confirmation box to display again. The
> confirmation box does display now when you use the web browser and
> follow the steps of the test but somehow it fails in our automatic
> tests. The test does pass for me when I execute it on my machine in
> the same way as the automatic tests do... so that's why I thought it
> was a timing issue. But there might be something else going on, I'm
> not sure.
>
> Jarek
>
> On Fri, Jul 3, 2009 at 10:53 AM, Shawn Jiang<genspring@gmail.com> wrote:
> >
> >
> > On Fri, Jul 3, 2009 at 2:53 AM, Jarek Gawor <jgawor@gmail.com> wrote:
> >>
> >> Shawn,
> >>
> >> The one failure in console/advanced on Tomcat is caused by fixing that
> >> prompting issue in the console. I'm hoping it's just a timing issue
> >
> > It's not a timing issue.  This is caused by a modification on
> > ConfirmMessageTag.java recently .
> >
> > After that  change,  dojo.js can't be found so that the prompting dialog
> > can't be display anymore.
> >
> > Revert the bvt change and update the code
> >
> > private static final String DOJO_BASE = "/dojo/dojo"
> >
> > to
> >
> > private static final String DOJO_BASE = "/dojo"
> >
> > can fix this.
> >>
> >> since its takes a bit of time to load all the Dojo stuff for the first
> >> time. So I just increased the wait time for the window to show up in
> >> that test.
> >>
> >> Jarek
> >>
> >> On Wed, Jul 1, 2009 at 9:31 PM, Shawn Jiang<genspring@gmail.com> wrote:
> >> > I can't recreate the same console/advanced failure in my local
> machine.
> >> > But I do find another console testsuite bug and filed a JIRA:
> >> > https://issues.apache.org/jira/browse/GERONIMO-4720   (patch
> provided)
> >> > The failure of enterprise-testsuite/sec-tests is related to
> >> > "run-as" propagation from a servlet to another servlet.   I'm looking
> >> > into
> >> > it and will provide a patch.
> >> > On Thu, Jun 25, 2009 at 11:58 PM, Jarek Gawor <jgawor@gmail.com>
> wrote:
> >> >>
> >> >> Based on running the testsuite yesterday and with fixes committed
> last
> >> >> night I *think* we should be passing all tests on Tomcat and fail
> >> >> enterprise-testsuite/sec-tests and webservices-testsuite/jaxws-tests
> >> >> on Jetty. The webservices-testsuite/jaxws-tests fails because of
> >> >> GERONIMO-4645. Not sure what's going on with
> >> >> enterprise-testsuite/sec-tests.
> >> >>
> >> >> Jarek
> >> >>
> >> >> On Thu, Jun 25, 2009 at 11:00 AM, Kevan Miller<
> kevan.miller@gmail.com>
> >> >> wrote:
> >> >> > A search of emails shows that our last successful automated build
> of
> >> >> > trunk
> >> >> > was on May 26th. I know that there have been increasing frustration
> >> >> > with
> >> >> > these recent build issues. We seem to be closing in on getting
> these
> >> >> > issues
> >> >> > resolved. I built last night. I built successfully, last night,
but
> >> >> > had
> >> >> > 7
> >> >> > testsuite failures -- 3 jetty, 4 tomcat.
> >> >> >
> >> >> > I think it would do us a lot of good to have a concerted effort
to
> >> >> > get
> >> >> > these
> >> >> > final issues resolved. Here are the test failures that I'm seeing:
> >> >> >
> >> >> > 3 common errors:
> >> >> >
> >> >> > [INFO] The following tests failed:
> >> >> > [INFO]     * console-testsuite/advanced -
> >> >> >
> >> >> >
> >> >> >
> /Users/kevan/geronimo/server/trunk/testsuite/console-testsuite/advanced/build.log
> >> >> > [INFO]     * enterprise-testsuite/sec-tests -
> >> >> >
> >> >> >
> >> >> >
> /Users/kevan/geronimo/server/trunk/testsuite/enterprise-testsuite/sec-tests/build.log
> >> >> > [INFO]     * webservices-testsuite/jaxws-tests -
> >> >> >
> >> >> >
> >> >> >
> /Users/kevan/geronimo/server/trunk/testsuite/webservices-testsuite/jaxws-tests/build.log
> >> >> >
> >> >> > 1 Tomcat unique failure:
> >> >> >
> >> >> > [INFO]     * web-testsuite/test-tomcat -
> >> >> >
> >> >> >
> >> >> >
> /Users/kevan/geronimo/server/trunk/testsuite/web-testsuite/test-tomcat/build.log
> >> >> >
> >> >> > Is this consistent with what others are seeing?
> >> >> >
> >> >> > --kevan
> >> >> >
> >> >
> >> >
> >> >
> >> > --
> >> > Shawn
> >> >
> >
> >
> >
> > --
> > Shawn
> >
>



-- 
Shawn

Mime
View raw message