geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vamsavardhana Reddy <c1vams...@gmail.com>
Subject Web app clustering with WADI in Geronimo Tomcat 2.1.4 broken?
Date Tue, 07 Jul 2009 06:57:10 GMT
I am trying to deploy a clustered web application in Geronimo Tomcat 2.1.4.
I have added <distributable/> in web.xml and <clustering-wadi/> in
geronimo-web.xml.  When I deploy the application, I am getting the following
deployment error:

xml problem for web app .
org.apache.geronimo.common.DeploymentException: xml problem for web app .
	at org.apache.geronimo.tomcat.deployment.TomcatModuleBuilder.getTomcatWebApp(TomcatModuleBuilder.java:318)
	at org.apache.geronimo.tomcat.deployment.TomcatModuleBuilder.createModule(TomcatModuleBuilder.java:207)
	at org.apache.geronimo.web25.deployment.AbstractWebModuleBuilder.createModule(AbstractWebModuleBuilder.java:179)
	at org.apache.geronimo.j2ee.deployment.SwitchingModuleBuilder.createModule(SwitchingModuleBuilder.java:94)
	at org.apache.geronimo.j2ee.deployment.EARConfigBuilder.getDeploymentPlan(EARConfigBuilder.java:307)
	at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:227)
	at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:134)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.apache.geronimo.gbean.runtime.ReflectionMethodInvoker.invoke(ReflectionMethodInvoker.java:34)
	at org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(GBeanOperation.java:124)
	at org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(GBeanInstance.java:867)
	at org.apache.geronimo.kernel.basic.BasicKernel.invoke(BasicKernel.java:239)
	at org.apache.geronimo.deployment.plugin.local.AbstractDeployCommand.doDeploy(AbstractDeployCommand.java:116)
	at org.apache.geronimo.deployment.plugin.local.DistributeCommand.run(DistributeCommand.java:61)
	at java.lang.Thread.run(Thread.java:595)
Caused by: org.apache.xmlbeans.XmlException: Invalid deployment
descriptor: errors:

error: cvc-complex-type.2.4a: Expected elements
'work-dir@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
clustering@http://geronimo.apache.org/xml/ns/j2ee/application-2.0
web-container@http://geronimo.apache.org/xml/ns/naming-1.2
host@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
cross-context@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
disable-cookies@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
valve-chain@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
listener-chain@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
tomcat-realm@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
manager@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
cluster@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
abstract-naming-entry@http://geronimo.apache.org/xml/ns/naming-1.2
ejb-ref@http://geronimo.apache.org/xml/ns/naming-1.2
ejb-local-ref@http://geronimo.apache.org/xml/ns/naming-1.2
service-ref@http://geronimo.apache.org/xml/ns/naming-1.2
resource-ref@http://geronimo.apache.org/xml/ns/naming-1.2
resource-env-ref@http://geronimo.apache.org/xml/ns/naming-1.2
message-destination@http://geronimo.apache.org/xml/ns/naming-1.2
security-realm-name@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1
service@http://geronimo.apache.org/xml/ns/deployment-1.2
persistence@http://java.sun.com/xml/ns/persistence' instead of
'clustering-wadi@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1'
here

Descriptor:
<xml-fragment xmlns:tom="http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1">
  <!--web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-2.0.1"
xmlns:app="http://geronimo.apache.org/xml/ns/j2ee/application-2.0"-->
  <dep:environment xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2">
    <dep:moduleId>
      <dep:groupId>packt-samples</dep:groupId>
      <dep:artifactId>helloworld-cluster</dep:artifactId>
      <dep:version>1.0</dep:version>
      <dep:type>war</dep:type>
    </dep:moduleId>
    <dep:dependencies/>
  </dep:environment>
  <tom:context-root>/helloworld-cluster</tom:context-root>
  <tom:clustering-wadi/>
</xml-fragment>

	at org.apache.geronimo.deployment.xmlbeans.XmlBeansUtil.validateDD(XmlBeansUtil.java:187)
	at org.apache.geronimo.tomcat.deployment.TomcatModuleBuilder.getTomcatWebApp(TomcatModuleBuilder.java:312)
	... 17 more

  Appears like the deployer is not liking the tag <clustering-wadi/>.

I do have  org.apache.geronimo.configs/tomcat6-clustering-wadi/2.1.4/car and
org.apache.geronimo.configs/tomcat6-clustering-builder-wadi/2.1.4/car
configurations started before deploying the web application.

I tried deploying the same application in Geronimo Tomcat 2.2-SNAPSHOT
server and got the same error.  Is the WADI clustering broken in Geronimo
Tomcat 2.1.4 and 2.2-SNAPSHOT?  The application deploys and runs as expected
in Geronimo Jetty 2.1.4.

-- 
Vamsi

Mime
View raw message