geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Jiang <genspr...@gmail.com>
Subject Re: "mvn eclipse:eclipse" fails for CXF plugin
Date Sat, 13 Jun 2009 14:35:08 GMT
: )
I met the same problem, and I just "project properties --> Libraries  -->
delete these error libs in the list."  to workaround this.

But I think there must be something wrong with the transitive dependency of
some module.

On Sat, Jun 13, 2009 at 10:26 PM, rahul.soa <rahul.soa@googlemail.com>wrote:

> Now, I have imported the CXF plugin in the eclipse, and have a few build
> path problem (missing jar files) after setting the classpath variable
> M2_REPO. For instance,
>
> Project 'geronimo-cxf-ejb' is missing required library:
> '/home/rahul/.m2/repository/com/sun/jdmk/jmxtools/1.2.1/jmxtools-1.2.1.jar'
>
>
> Project 'geronimo-cxf-ejb' is missing required library:
> '/home/rahul/.m2/repository/com/sun/jmx/jmxri/1.2.1/jmxri-1.2.1.jar'
>
>
> Project 'geronimo-cxf-ejb' is missing required library:
> '/home/rahul/.m2/repository/javax/jms/jms/1.1/jms-1.1.jar'
>
> Project 'geronimo-cxf' is missing required library:
> '/home/rahul/.m2/repository/com/sun/jdmk/jmxtools/1.2.1/jmxtools-1.2.1.jar'
> geronimo-cxf
>
>
> Project 'geronimo-cxf' is missing required library:
> '/home/rahul/.m2/repository/com/sun/jmx/jmxri/1.2.1/jmxri-1.2.1.jar'
> geronimo-cxf
>
>
> Project 'geronimo-cxf' is missing required library:
> '/home/rahul/.m2/repository/javax/jms/jms/1.1/jms-1.1.jar'
>
>
> Do I have to include them manually under /.m2 ? Am I missing something?
> Please suggest a better option.
>
>
> Many Thanks for your quick reply.
>
> Best Regards,
> Rahul
>
>
>
> On Sat, Jun 13, 2009 at 3:58 PM, rahul.soa <rahul.soa@googlemail.com>wrote:
>
>> Thanks Shawn,
>>
>> I did the same and it worked for me too.
>>
>> Best Regards,
>> Rahul
>>
>>
>> On Sat, Jun 13, 2009 at 2:13 PM, Shawn Jiang <genspring@gmail.com> wrote:
>>
>>> I checked out activemq trunk and made a local build to resolve a similar
>>> problem before.  FYI.
>>>
>>>
>>> On Sat, Jun 13, 2009 at 7:49 PM, rahul.soa <rahul.soa@googlemail.com>wrote:
>>>
>>>> Hello Devs,
>>>>
>>>> I am trying to import some modules from Geronimo/plugins in eclipse for
>>>> the development. I am trying with CXF plugin, so for this I am running the
>>>> following command under
>>>>
>>>> [rahul@localhost cxf]$ pwd
>>>> /home/rahul/server/plugins/cxf
>>>> [rahul@localhost cxf]$ mvn eclipse:eclipse -e
>>>>
>>>> and I get the following error:
>>>>
>>>>
>>>>
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] Building Geronimo Plugins, CXF :: EJB
>>>> [INFO]    task-segment: [eclipse:eclipse]
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] Preparing eclipse:eclipse
>>>> [INFO] snapshot org.apache.geronimo.configs:openejb:2.2-SNAPSHOT:
>>>> checking for updates from apache.org
>>>> [INFO] snapshot org.apache.geronimo.configs:openejb:2.2-SNAPSHOT:
>>>> checking for updates from apache.snapshots
>>>> [INFO] snapshot org.apache.geronimo.configs:openejb:2.2-SNAPSHOT:
>>>> checking for updates from apache.nexus.snapshots
>>>> [INFO] snapshot org.apache.geronimo.configs:openejb:2.2-SNAPSHOT:
>>>> checking for updates from apache-snapshots
>>>> [INFO] snapshot org.apache.geronimo.configs:openejb:2.2-SNAPSHOT:
>>>> checking for updates from codehaus-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:system-database:2.2-SNAPSHOT: checking for
>>>> updates from apache.org
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:system-database:2.2-SNAPSHOT: checking for
>>>> updates from apache.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:system-database:2.2-SNAPSHOT: checking for
>>>> updates from apache.nexus.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:system-database:2.2-SNAPSHOT: checking for
>>>> updates from apache-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:system-database:2.2-SNAPSHOT: checking for
>>>> updates from codehaus-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.plugins:system-database:2.2-SNAPSHOT: checking for
>>>> updates from apache.org
>>>> [INFO] snapshot
>>>> org.apache.geronimo.plugins:system-database:2.2-SNAPSHOT: checking for
>>>> updates from apache.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.plugins:system-database:2.2-SNAPSHOT: checking for
>>>> updates from apache.nexus.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.plugins:system-database:2.2-SNAPSHOT: checking for
>>>> updates from apache-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.plugins:system-database:2.2-SNAPSHOT: checking for
>>>> updates from codehaus-snapshots
>>>> [INFO] snapshot org.apache.geronimo.configs:derby:2.2-SNAPSHOT: checking
>>>> for updates from apache.org
>>>> [INFO] snapshot org.apache.geronimo.configs:derby:2.2-SNAPSHOT: checking
>>>> for updates from apache.snapshots
>>>> [INFO] snapshot org.apache.geronimo.configs:derby:2.2-SNAPSHOT: checking
>>>> for updates from apache.nexus.snapshots
>>>> [INFO] snapshot org.apache.geronimo.configs:derby:2.2-SNAPSHOT: checking
>>>> for updates from apache-snapshots
>>>> [INFO] snapshot org.apache.geronimo.configs:derby:2.2-SNAPSHOT: checking
>>>> for updates from codehaus-snapshots
>>>> [INFO] snapshot org.apache.geronimo.modules:geronimo-derby:2.2-SNAPSHOT:
>>>> checking for updates from apache.org
>>>> [INFO] snapshot org.apache.geronimo.modules:geronimo-derby:2.2-SNAPSHOT:
>>>> checking for updates from apache.snapshots
>>>> [INFO] snapshot org.apache.geronimo.modules:geronimo-derby:2.2-SNAPSHOT:
>>>> checking for updates from apache.nexus.snapshots
>>>> [INFO] snapshot org.apache.geronimo.modules:geronimo-derby:2.2-SNAPSHOT:
>>>> checking for updates from apache-snapshots
>>>> [INFO] snapshot org.apache.geronimo.modules:geronimo-derby:2.2-SNAPSHOT:
>>>> checking for updates from codehaus-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:activemq-broker:2.2-SNAPSHOT: checking for
>>>> updates from apache.org
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:activemq-broker:2.2-SNAPSHOT: checking for
>>>> updates from apache.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:activemq-broker:2.2-SNAPSHOT: checking for
>>>> updates from apache.nexus.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:activemq-broker:2.2-SNAPSHOT: checking for
>>>> updates from apache-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.configs:activemq-broker:2.2-SNAPSHOT: checking for
>>>> updates from codehaus-snapshots
>>>> [INFO] snapshot org.apache.geronimo.plugins:activemq:2.2-SNAPSHOT:
>>>> checking for updates from apache.org
>>>> [INFO] snapshot org.apache.geronimo.plugins:activemq:2.2-SNAPSHOT:
>>>> checking for updates from apache.snapshots
>>>> [INFO] snapshot org.apache.geronimo.plugins:activemq:2.2-SNAPSHOT:
>>>> checking for updates from apache.nexus.snapshots
>>>> [INFO] snapshot org.apache.geronimo.plugins:activemq:2.2-SNAPSHOT:
>>>> checking for updates from apache-snapshots
>>>> [INFO] snapshot org.apache.geronimo.plugins:activemq:2.2-SNAPSHOT:
>>>> checking for updates from codehaus-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq:2.2-SNAPSHOT: checking for
>>>> updates from apache.org
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq:2.2-SNAPSHOT: checking for
>>>> updates from apache.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq:2.2-SNAPSHOT: checking for
>>>> updates from apache.nexus.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq:2.2-SNAPSHOT: checking for
>>>> updates from apache-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq:2.2-SNAPSHOT: checking for
>>>> updates from codehaus-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq-management:2.2-SNAPSHOT:
>>>> checking for updates from apache.org
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq-management:2.2-SNAPSHOT:
>>>> checking for updates from apache.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq-management:2.2-SNAPSHOT:
>>>> checking for updates from apache.nexus.snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq-management:2.2-SNAPSHOT:
>>>> checking for updates from apache-snapshots
>>>> [INFO] snapshot
>>>> org.apache.geronimo.modules:geronimo-activemq-management:2.2-SNAPSHOT:
>>>> checking for updates from codehaus-snapshots
>>>> [INFO] snapshot org.apache.activemq:activemq-core:5.3-SNAPSHOT: checking
>>>> for updates from apache.org
>>>> [INFO] snapshot org.apache.activemq:activemq-core:5.3-SNAPSHOT: checking
>>>> for updates from apache.snapshots
>>>> [INFO] snapshot org.apache.activemq:activemq-core:5.3-SNAPSHOT: checking
>>>> for updates from apache.nexus.snapshots
>>>> [INFO] snapshot org.apache.activemq:activemq-core:5.3-SNAPSHOT: checking
>>>> for updates from apache-snapshots
>>>> [INFO] snapshot org.apache.activemq:activemq-core:5.3-SNAPSHOT: checking
>>>> for updates from codehaus-snapshots
>>>> [INFO] snapshot org.apache.activemq:activemq-parent:5.3-SNAPSHOT:
>>>> checking for updates from apache.org
>>>> [INFO] snapshot org.apache.activemq:activemq-parent:5.3-SNAPSHOT:
>>>> checking for updates from apache.snapshots
>>>> [INFO] snapshot org.apache.activemq:activemq-parent:5.3-SNAPSHOT:
>>>> checking for updates from apache.nexus.snapshots
>>>> [INFO] snapshot org.apache.activemq:activemq-parent:5.3-SNAPSHOT:
>>>> checking for updates from apache-snapshots
>>>> [INFO] snapshot org.apache.activemq:activemq-parent:5.3-SNAPSHOT:
>>>> checking for updates from codehaus-snapshots
>>>> Downloading:
>>>> http://people.apache.org/repo/m2-snapshot-repository/org/apache/activemq/activemq-parent/5.3-SNAPSHOT/activemq-parent-5.3-20090417.072917-276.pom
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [ERROR] BUILD ERROR
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] Error building POM (may not be this project's POM).
>>>>
>>>>
>>>> Project ID: null:activemq-core:bundle:null
>>>>
>>>> Reason: Cannot find parent: org.apache.activemq:activemq-parent for
>>>> project: null:activemq-core:bundle:null for project
>>>> null:activemq-core:bundle:null
>>>>
>>>>
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] For more information, run Maven with the -e switch
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] Total time: 12 minutes 40 seconds
>>>> [INFO] Finished at: Sat Jun 13 15:23:16 CEST 2009
>>>> [INFO] Final Memory: 58M/63M
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [rahul@localhost cxf]$
>>>>
>>>>
>>>> It seems that activemq snapshot is not deployed correctly or something
>>>> (not sure though). I encountered the similar issue with activemq lib while
>>>> building Geronimo in the past, that time I build the brand new server to
>>>> solve that problem.
>>>>
>>>> Is there a way to solve the above problem without building the server
>>>> again from the begining?
>>>>
>>>>
>>>> Many Thanks for your reply.
>>>>
>>>>
>>>> Best Regards,
>>>> Rahul
>>>>
>>>
>>>
>>>
>>> --
>>> Shawn
>>>
>>
>>
>


-- 
Shawn

Mime
View raw message