geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: [BUILD 2.1.4] [Error] Plugin's descriptor contains the wrong version: 2.0-alpha-1-SNAPSHOT
Date Sun, 28 Jun 2009 07:38:25 GMT
Can you try building with maven 2.0.9 or 2.0.10?  I think we built the  
released 2.1.4 with maven 2.0.9.  However, a svn tag shouldn't be  
using any snapshot versions of anything.  Can you confirm which source  
you checked out?

thanks
david jencks

On Jun 27, 2009, at 9:14 PM, 李伟超 wrote:

> Apache Maven 2.1.0 (r755702; 2009-03-19 03:10:27+0800)
> Java version: 1.5.0_19
> Java home: /home/mark/install/jdk1.5.0_19/jre
> Default locale: zh_CN, platform encoding: UTF-8
> OS name: "linux" version: "2.6.28-11-generic" arch: "i386" Family:  
> "unix"
>
>
> 2009/6/28 李伟超 <markoodoo@gmail.com>
> i build v2.1.4 from svn-tag because i think it will be more smoothly  
> than from trunk, but not luck.
>
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Building Geronimo Plugins, ActiveMQ :: Portlets
> [INFO]    task-segment: [install]
> [INFO]  
> ------------------------------------------------------------------------
> [INFO]  
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Internal error in the plugin manager getting plugin  
> 'org.codehaus.mojo.jspc:jspc-maven-plugin': Plugin  
> 'org.codehaus.mojo.jspc:jspc-maven-plugin:2.0-alpha-1-20070806' has  
> an invalid descriptor:
> 1) Plugin's descriptor contains the wrong version: 2.0-alpha-1- 
> SNAPSHOT
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Trace
> org.apache.maven.lifecycle.LifecycleExecutionException: Internal  
> error in the plugin manager getting plugin  
> 'org.codehaus.mojo.jspc:jspc-maven-plugin': Plugin  
> 'org.codehaus.mojo.jspc:jspc-maven-plugin:2.0-alpha-1-20070806' has  
> an invalid descriptor:
> 1) Plugin's descriptor contains the wrong version: 2.0-alpha-1- 
> SNAPSHOT
>     at  
> org 
> .apache 
> .maven 
> .lifecycle 
> .DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java: 
> 1521)
>     at  
> org 
> .apache 
> .maven 
> .lifecycle 
> .DefaultLifecycleExecutor 
> .bindPluginToLifecycle(DefaultLifecycleExecutor.java:1479)
>     at  
> org 
> .apache 
> .maven 
> .lifecycle 
> .DefaultLifecycleExecutor 
> .constructLifecycleMappings(DefaultLifecycleExecutor.java:1245)
>     at  
> org 
> .apache 
> .maven 
> .lifecycle 
> .DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java: 
> 518)
>     at  
> org 
> .apache 
> .maven 
> .lifecycle 
> .DefaultLifecycleExecutor 
> .executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)
>     at  
> org 
> .apache 
> .maven 
> .lifecycle 
> .DefaultLifecycleExecutor 
> .executeTaskSegments(DefaultLifecycleExecutor.java:332)
>     at  
> org 
> .apache 
> .maven 
> .lifecycle 
> .DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
>     at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
>     at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
>     at org.apache.maven.cli.MavenCli.main(MavenCli.java:356)
>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     at  
> sun 
> .reflect 
> .NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>     at  
> sun 
> .reflect 
> .DelegatingMethodAccessorImpl 
> .invoke(DelegatingMethodAccessorImpl.java:25)
>     at java.lang.reflect.Method.invoke(Method.java:585)
>     at  
> org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>     at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>     at  
> org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>     at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.plugin.PluginManagerException: Plugin  
> 'org.codehaus.mojo.jspc:jspc-maven-plugin:2.0-alpha-1-20070806' has  
> an invalid descriptor:
> 1) Plugin's descriptor contains the wrong version: 2.0-alpha-1- 
> SNAPSHOT
>     at  
> org 
> .apache 
> .maven 
> .plugin.DefaultPluginManager.addPlugin(DefaultPluginManager.java:323)
>     at  
> org 
> .apache 
> .maven 
> .plugin 
> .DefaultPluginManager 
> .verifyVersionedPlugin(DefaultPluginManager.java:217)
>     at  
> org 
> .apache 
> .maven 
> .plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java: 
> 177)
>     at  
> org 
> .apache 
> .maven 
> .lifecycle 
> .DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java: 
> 1517)
>     ... 17 more
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Total time: 16 minutes 6 seconds
> [INFO] Finished at: Sun Jun 28 09:14:54 CST 2009
> [INFO] Final Memory: 159M/587M
> [INFO]  
> ------------------------------------------------------------------------
>


Mime
View raw message