geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarek Gawor <jga...@gmail.com>
Subject Re: G 2.2 snapshot build error (activemq-parent not found)
Date Mon, 15 Jun 2009 05:21:19 GMT
Is there some documentation describing nexus setup at apache? I'm
really confused by the different repositories. For example, the
apache-6.pom points to http://repository.apache.org/snapshots url. But
https://repository.apache.org/index.html#view-repositories does not
list that exact repository url. From browsing the repos it looks to me
like http://repository.apache.org/snapshots is really just an alias
for https://repository.apache.org/content/groups/snapshots-group/. And
that repo looks like a grouping of old snapshots from people and the
new nexus snapshots location. So it seems like
http://repository.apache.org/snapshots already contains the old and
new snapshots.

And if I have this right, adding the old snapshot repo to activemq
module won't work (since it's redundant) and there are some activemq
artifacts already published to
https://repository.apache.org/content/repositories/snapshots. So I
think there is something else going here.

Jarek

On Sat, Jun 13, 2009 at 1:58 PM, David Jencks<david_jencks@yahoo.com> wrote:
> Usually we yell at people posting user list questions on the dev list....
> this is actually more appropriate for the dev list.
>
> I suspect the problem is that activemq is not publishing snapshots to the
> apache nexus instance.
>
> I think the possible solutions are either
> - add the old file based repo into the amq module
> - get amq onto the nexus repo.
>
> The second would IMO be a lot better but more work.  I have a bunch of stuff
> to finish up before I can look into this.
>
> thanks
> david jencks
>
> On Jun 13, 2009, at 8:33 AM, Peter Petersson wrote:
>
>> For some days now I have hit this build error (starting from a clean local
>> repo).
>> Is this to be expected due to the current flux of the project or is there
>> a simple fix for this ?
>> regards
>>  peter petersson
>>
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Building Geronimo Plugins, ActiveMQ v5 :: Core
>> [INFO]    task-segment: [clean, install]
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] [clean:clean]
>> [INFO] [genesis:validate-configuration {execution: default}]
>> [INFO] snapshot org.apache.activemq:activemq-core:5.3-SNAPSHOT: checking
>> for updates from apache.snapshots
>> [INFO] snapshot org.apache.activemq:activemq-core:5.3-SNAPSHOT: checking
>> for updates from codehaus.snapshots
>> [INFO] snapshot org.apache.activemq:activemq-parent:5.3-SNAPSHOT: checking
>> for updates from apache.snapshots
>> [INFO] snapshot org.apache.activemq:activemq-parent:5.3-SNAPSHOT: checking
>> for updates from codehaus.snapshots
>> Downloading:
>> http://people.apache.org/repo/m2-snapshot-repository/org/apache/activemq/activemq-parent/5.3-SNAPSHOT/activemq-parent-5.3-20090417.072917-276.pom
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>>
>> Project ID: null:activemq-core:bundle:null
>>
>> Reason: Cannot find parent: org.apache.activemq:activemq-parent for
>> project: null:activemq-core:bundle:null for project
>> null:activemq-core:bundle:null
>>
>

Mime
View raw message