geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Ortega (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-492) GEP v2.1.1 installation error in eclipse Ganymede JEE package
Date Thu, 11 Jun 2009 10:09:07 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-492?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12718390#action_12718390
] 

Carlos Ortega commented on GERONIMODEVTOOLS-492:
------------------------------------------------

Possible manual workaround (For Windows XP):
======================================

1) Download latest version of GEP deployable.zip :
     ( I downloaded V2.1.4: geronimo-eclipse-plugin-2.1.4-deployable.zip
       from: http://archive.eu.apache.org/dist/geronimo/eclipse/2.1.4/ )

2) Unzip to any directory you want:
      ( I used D:\Temp as my Download and Unzip directory,
        so after I unzipped the .zip file I got:
        
         D:\Temp\eclipse #directory
                                features #subdirectory
                                plugin #subdirectory
                                LICENCE.txt # text file
                                NOTICE.txt # text file
                                PLUGIN_RELEASE-NOTES-2.1.4.txt #text file

3) Copy the contents of the recently created "features" subdirectory to
     the Eclipse installation "features" subdirectory.
      (I used C:\Program Files\eclipse as my eclipse installation directory,
       so I just copy the content:

                org.apache.geronimo.v21.feature_2.1.4 #subdirectory

       to:

                C:\Program Files\eclipse\features

4) Copy the contents of the recently created "plugins" subdirectory to
     the Eclipse installation "plugins" subdirectory.
     (I used C:\Program Files\eclipse as my eclipse installation directory,
      so I just copy the content:

               org.apache.geronimo.jee.v21.jaxbmodel_2.1.4.jar #jar file
               org.apache.geronimo.runtime.common_2.1.4.jar #jar file
               org.apache.geronimo.runtime.v20_2.1.4.jar #jar file
               org.apache.geronimo.runtime.v21_2.1.4.jar #jar file
               org.apache.geronimo.st.core_2.1.4.jar #jar file
               org.apache.geronimo.st.schemas_2.1.4.jar #jar file
               org.apache.geronimo.st.ui_2.1.4.jar #jar file
               org.apache.geronimo.st.v20.core_2.1.4.jar #jar file
               org.apache.geronimo.st.v20.ui_2.1.4.jar #jar file
               org.apache.geronimo.st.v21.core_2.1.4.jar #jar file
               org.apache.geronimo.st.v21.ui_2.1.4.jar #jar file


       to:

                C:\Program Files\eclipse\plugins

5) Edit the eclipse.ini file and change the parameters to increase
      the default setting for maximum PermGen size for your
      Eclipse installation (especially if you have installed
      Sun's JDK 1.5.0_x in Windows Platform) to prevent
      "java.lang.OutOfMemoryError: PermGen" errors:

      (In my case I edited the C:\Program Files\eclipse\eclipse.ini file,
       previously, the content was:
       
                 -showsplash
                 org.eclipse.platform
                 --launcher.XXMaxPermSize
                 256M
                 -framework
                 plugins\org.eclipse.osgi_3.4.3.R34x_v20081215-1030.jar
                 -vmargs
                 -Dosgi.requiredJavaVersion=1.5
                 -Xms40m
                 -Xmx512m

         After edition, the final content was:

                 -showsplash
                 org.eclipse.platform
                 --launcher.XXMaxPermSize
                 256M
                 -framework
                 plugins\org.eclipse.osgi_3.4.3.R34x_v20081215-1030.jar
                -Dosgi.requiredJavaVersion=1.5
                -Xms128m
                -Xmx512m
                -XX:MaxPermSize=128m

6 - Save the eclipse.ini file and restart eclipse with -clean option to
      clean any cache data used by the OSGi framework and eclipse runtime.
      (In my case, I typed:
       
                     "C:\Program Files\eclipse\eclipse.exe" -clean
       
        In the Start/Run option within Windows.

7 - Verify the installation. There are 2 options:

       a) Verify the recently installed plugins from within "servers" view inside Eclipse:
             
             -Window / Show View / Servers
             -Right Click on Servers view / New / Server
             -Within the Apache folder there should be the
              "Apache Geronimo v 2.0 Server" and "Apache Geronimo v 2.1 Server"
              server types.


        b) Verify the "About Eclipse Platform" dialog.

             -Help / About Eclipse Platform
             -There should appear the "G" eronimo Logo. And if you
               click it, then there should appear the "About Eclipse Platform Features"
               dialog showing the Apache Geronimo v2.1 Server Adapter features.

Hope this help.
Regards 

> GEP v2.1.1 installation error in eclipse Ganymede JEE package
> -------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-492
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-492
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 2.1.1
>         Environment: OS: Windows XP SP2 and Ubuntu 8.04
> Eclipse: Eclipse Ganymede JEE package, based on Version: 3.4.0 Build id: I20080617-2000
> JDK: IBM SDK 5 sr6b
>            Reporter: Forrest Xia
>            Assignee: Ted Kirby
>             Fix For: 2.1.2
>
>
> Steps:
> 1. Download and lauch eclipse ganymede
> 2. click "Software Updates..."->"Available Software" to add a site point to http://www.apache.org/dist/geronimo/eclipse/updates
> 3. Choose "Geronimo v2.1 Server Adapter" to install
> Symptom:
> An install error shows up as follows:
> Cannot complete the request.  See the details.
> Unsatisfied dependency: [org.apache.geronimo.v21.feature.feature.group 2.1.1] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jst.feature.group/[2.0.0,3.0.0)
> Unsatisfied dependency: [org.apache.geronimo.feature.feature.group 2.1.1] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jst.feature.group/[2.0.0,3.0.0)
> Unsatisfied dependency: [org.apache.geronimo.feature.feature.group 2.1.1] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jst.feature.group/[2.0.0,3.0.0)
> Unsatisfied dependency: [org.apache.geronimo.v21.feature.feature.group 2.1.1] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jst.feature.group/[2.0.0,3.0.0)
> Unsatisfied dependency: [org.apache.geronimo.v21.feature.feature.group 2.1.1] requiredCapability:
org.eclipse.equinox.p2.iu/org.apache.geronimo.feature.feature.group/[2.1.1,2.1.1]

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message