geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-4672) Managed oracle datasource does not properly perform rollbacks
Date Wed, 03 Jun 2009 21:02:07 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-4672?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12716064#action_12716064
] 

David Jencks commented on GERONIMO-4672:
----------------------------------------

Which tranql wrapper did you use for the local-tx datasource? I wonder if this is related
to the commit-before-autocommit setting?  (although it's hard to see how)

> Managed oracle datasource does not properly perform rollbacks
> -------------------------------------------------------------
>
>                 Key: GERONIMO-4672
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4672
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: persistence
>    Affects Versions: 2.1.3
>         Environment: Geronimo 2.1.3 with java 1.5 on linux and windows
>            Reporter: Ralf Baumhof
>
> The oracle datasource is configured with the following parameters:
> Type: thin
> Transactions: none
> jar file: ojdbc14.jar from oracle 10g Express
> db server: oracle 10g express, 11g express and 11g production
> The application uses OpenJpa for persistence layer. With PostgreSQL database Server all
worked fine. When migrating to oracle we discovered that rollback is not properly performed.
> Test:
> In one table a column is dropped. The application tries to insert data. This result in
an persistence exception. A rollback is performed (that's what the server tells in the log)
but data inserted prior to the error point remains comitted. We solved the problem by configuring
an XA datasource, but this version should also work.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message