Hello everyone,

As you know I am working on the support of ws-security module, so I did some research about integrating the modules in Apache Geronimo for the same.

For the integrating/enabling WS-Security support, I think we need to have the following jars and modules in Geronimo:

Apache CXF:

For WS-Security support we need to have following jar files from the CXF:

- bcprov-jdk15.jar
- xalan.jar
- serializer.jar
- wss4j.jar
- xmlsec.jar


Apache Axis2

1. We need to integrate "Rampart*" module of axis2,

2. for step 1, need to download the Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files corresponding to JDK version and extract the jar files local_policy.jar and US_export_policy.jar to $JAVA_HOME/jre/lib/security

3. for step 1, need to download bouncycastle according to java version separately

*Rampart is the security module of Axis2


Please let me know if I am missing something and please also guide me how can I get them in Geronimo.

Thanks in advance.

Regards,
Rahul