geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: [blueprint] itests failing with NoClassDefFoundError
Date Wed, 20 May 2009 19:25:19 GMT

On May 20, 2009, at 11:20 AM, Guillaume Nodet wrote:

> Is your m2 repository in ~/.m2/repository without any other location
> defined in ~/.m2/settings.xml ?
> It seems pax-exam is broken and only support the local repository in
> the default location.  If you do that, it should build just fine.

Ok, understood this sentence, "Do you use the default m2 repository ?  
That may be the problem" to imply using the default repo was the  
problem.  Which lead me to still wonder what was the right approach.

Not sure what bad state I had in ~/.m2/repository that caused things  
to fail when I tried with all default settings but trying with a clean  
repo at ~/.m2/repository vs. -Dmaven.repo.local=tmprepo finally works.

-David


>
>
> 2009/5/20 David Blevins <david.blevins@visi.com>:
>>
>> On May 19, 2009, at 5:22 PM, David Blevins wrote:
>>
>>> Would love to know what the magic settings.xml data is and if  
>>> there's some way to get it into the root pom.xml.
>>
>> Still need the right settings.  I'm fine picking through your  
>> settings.xml (minus passwords) if you're unsure what the magic  
>> settings are.
>>
>>
>> -David
>>
>>
>
>
>
> -- 
> Cheers,
> Guillaume Nodet
> ------------------------
> Blog: http://gnodet.blogspot.com/
> ------------------------
> Open Source SOA
> http://fusesource.com
>


Mime
View raw message