geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: [blueprint] itests failing with NoClassDefFoundError
Date Tue, 19 May 2009 21:01:22 GMT
Gave 2.0.10 a try.  No luck so tried the clean repo, also no luck.

$ svn up
At revision 776452.

$ mvn clean install -Dmaven.repo.local=repo > blueprint-build.log

$ cat blueprint-itests/target/surefire-reports/*.txt > blueprint- 
surefire.txt

And the results:

   http://people.apache.org/~dblevins/blueprint-build.log
   http://people.apache.org/~dblevins/blueprint-surefire.txt


If you haven't already, give a clean repo a try yourself.  Could be  
there's local state in your repo that makes things work -- wouldn't be  
the first or last time anything like that ever happened.


-David


On May 18, 2009, at 9:49 PM, Jarek Gawor wrote:

> What version of maven are you using? I had problems with 2.0.9 but
> works fine for me with 2.0.10. I don't know if this will help but
> maybe try with clean m2 repo? itests pull in a lot of stuff... maybe
> we need to tie down some plugin version.
>
> Jarek
>
> On Mon, May 18, 2009 at 10:33 PM, David Blevins <david.blevins@visi.com 
> > wrote:
>> Trying to get a clean build on the blueprint code.  Getting several  
>> errors
>> due to what seems like an invalid bundle config.
>>
>> ERROR: Error starting file:bundles/blueprint-core_1.0.0.SNAPSHOT.jar
>> (org.osgi.framework.BundleException: Unresolved constraint in  
>> bundle 5:
>> package; (&(package=org.osgi.service.blueprint.reflect) 
>> (version>=1.0.0)))
>> org.osgi.framework.BundleException: Unresolved constraint in bundle  
>> 5:
>> package; (&(package=org.osgi.service.blueprint.reflect) 
>> (version>=1.0.0))
>>        at org.apache.felix.framework.Felix.resolveBundle(Felix.java: 
>> 3090)
>>        at org.apache.felix.framework.Felix.startBundle(Felix.java: 
>> 1439)
>>        at
>> org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:984)
>>        at
>> org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java: 
>> 263)
>>
>> I'm guessing that 1.0.0.SNAPSHOT is considered greater than 1.0.0 and
>> something else is going on.
>>
>> What's the trick to getting these tests to run?
>>
>> -David
>>
>>
>


Mime
View raw message