geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Delos Dai (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GERONIMODEVTOOLS-535) Add support for installing from update site for IBM RAD v7.5
Date Wed, 18 Mar 2009 09:41:50 GMT

     [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-535?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Delos Dai updated GERONIMODEVTOOLS-535:
---------------------------------------

    Attachment: 535_trunk.patch

Donald,

For trunk, a new feature "org.apache.geronimo.v22.feature" is created, but the patch  doesn't
cover this.  So I attach an additional patch for trunk.

Could you help to apply it? 

Thanks!

> Add support for installing from update site for IBM RAD v7.5
> ------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-535
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-535
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 2.1.3
>         Environment: IBM RAD v7.5
>            Reporter: Delos Dai
>            Assignee: Delos Dai
>             Fix For: 2.2.0, 2.1.4
>
>         Attachments: 535_trunk.patch, GERONIMODEVTOOLS-535.patch
>
>
> Now, in feature.xml of GEP, we have this snippet:
> <requires>
>       <import feature="org.eclipse.jst" version="2.0.0" match="greaterOrEqual"/>
> </requires>  
> Since no "org.eclipse.jst" feature exist in RAD , we have to replace "org.eclipse.jst"
feature with the sub-features of "org.eclipse.jst". 
> The section above can be replaced with this snippet:
> <requires>
>   <import feature="org.eclipse.jst.common_core.feature" version="2.0.0.v200706041905-1007w311817231426"

> 		match="greaterOrEqual"/>     	
> 	<import feature="org.eclipse.jst.server_ui.feature" version="2.0.2.v200802150100-77-CT9yJXEkuiKVeQrclqTHQ3648"
> 		match="greaterOrEqual"/>
> 	<import feature="org.eclipse.jst.server_adapters.feature" version="2.0.2.v200802150100-787KE8iDUUEF6GwKwpHEQ"
> 		match="greaterOrEqual"/>
> 	<import feature="org.eclipse.jst.web_ui.feature" version="2.0.2.v200802150100-7B1DzCkuNa_RPevwkwB1iJ6z-0RH"

> 		match="greaterOrEqual"/>
>   	<import feature="org.eclipse.jst.enterprise_ui.feature" version="2.0.2.v200802150100-7b7_Es8EU6AXOV9QLJSees1SQoYQ"
> 		match="greaterOrEqual"/>
> </requires>
> The sole plugin of "org.eclipse.jst" feature and optional sub-feature "org.eclipse.jst.webpageeditor.feature"
can't be found in the plugin list of RAD.  GEP doesn't require these two items, then don't
need to add them into the required section.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message