geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "X (JIRA)" <...@geronimo.apache.org>
Subject [jira] Commented: (DAYTRADER-62) Unclear how to install client apps
Date Sat, 07 Mar 2009 13:52:56 GMT

    [ https://issues.apache.org/jira/browse/DAYTRADER-62?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12679874#action_12679874
] 

X commented on DAYTRADER-62:
----------------------------

I got an error when installing ActiveMQ dependency, which is maybe related to your JMS resource
error.
I have manually installed it in Maven repos:
mvn install:install-file -DgroupId=org.apache.activemq -DartifactId=activemq-core -Dversion=4.1.2-G647819
-Dpackaging=jar -Dfile=<path_to_apache-activemq-4.1.2.jar>

It works fine both on the web client and the server side. 
The only thing that doesn't worked, following the README, is the ws-client and the streamer-client.

Here is my environment decription:
Daytrader version: 2.2-SNAPSHOT (trunk: http://svn.apache.org/repos/asf/geronimo/daytrader/trunk/)
Apache Geronimo version: 2.1.3 (geronimo-tomcat6-javaee5-2.1.3)
Maven version: 2.0.9
Java version: 1.6.0_11
OS name: "linux" version: "2.6.18-6-686" arch: "i386" Family: "unix"

> Unclear how to install client apps
> ----------------------------------
>
>                 Key: DAYTRADER-62
>                 URL: https://issues.apache.org/jira/browse/DAYTRADER-62
>             Project: DayTrader
>          Issue Type: Bug
>            Reporter: Steve Blackburn
>
> Running with the current svn head (and following advice in DAYTRADER-61), I successfully
got the system to install without problems.  I can run daytrader through the browser.
> However, I would like to run the clients directly, as per the README.   Simply following
the instructions in the new version of the README does not work (because the client apps have
not been deployed).
> In a previous version, I deployed the clients via an ear:
> ${GERONIMO_HOME}/bin/deploy.sh deploy modules/ear/target/daytrader-ear-1.2-SNAPSHOT.ear
plans/daytrader-2.0.1-plan.xml
> The current build produces a similar ear, however, this will not install.
> I noticed that in the tomcat directory there were plugins for each of the clients.  
No such plugins in the jetty dir.   I blindly modified the pom.xml to create and install the
jetty plugins, but I can't deploy them.  I'm using a jetty geronimo.  I could switch, if that
would help, but in any case, there seems to be some kind of inconsistency here (or else I
just don't understand it!)
> If someone could help with this I'd really appreciate it.
> BTW, the recent activity on daytrader has been great!  Thanks.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message