geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Larry Zhang (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GERONIMODEVTOOLS-564) Fail to create plugin via GEP
Date Tue, 17 Mar 2009 10:14:50 GMT

     [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-564?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Larry Zhang updated GERONIMODEVTOOLS-564:
-----------------------------------------

    Attachment: 562+564.patch

Hi,Tim,I'm very sorry for the last two patches. 
Today, I tested the gep again and found another reason for this jira: 
In GeronimoServerPluginManager.installPlugins step 2, when the plugin doesn't have version
number,  may cause the error below:
java.lang.IllegalArgumentException: Artifact org.apache.geronimo.samples/calculator-stateless-ear//car
is not fully resolved
at org.apache.geronimo.kernel.config.SimpleConfigurationManager.isLoaded(SimpleConfigurationManager.java:103)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:618)
	at org.apache.geronimo.gbean.runtime.ReflectionMethodInvoker.invoke(ReflectionMethodInvoker.java:34)
	at org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(GBeanOperation.java:124)
	at org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(GBeanInstance.java:867)
	at org.apache.geronimo.kernel.basic.BasicKernel.invoke(BasicKernel.java:239)
	at org.apache.geronimo.kernel.KernelGBean.invoke(KernelGBean.java:342)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
I have fixed it . This time , I made one patch both for 562 and 564.  

And for your errors , do you use the geronimo 2.1.4-snapshot ? If the answer is yes,  maybe
you need to mofidy your plugins ,because in  2.1.4-snapshot ,the org.apache.geronimo.configs/tomcat6/2.1.4/car
 was replaced by org.apache.geronimo.configs/tomcat6/2.1.4-SNAPSHOT/car.


> Fail to create plugin via GEP
> -----------------------------
>
>                 Key: GERONIMODEVTOOLS-564
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-564
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 2.1.4
>         Environment: os:wind2003 jdk:1.5
>            Reporter: viola.lu
>            Assignee: Tim McConnell
>         Attachments: 562+564.patch, 564.patch
>
>
> Steps:
> 1.Define a G server runtime, and right-click to open it
> 2.Open "plugin" page, click "convert app to plugin"->choose any item you would like->next,
all fields are empty, and fail to convert it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message