geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <>
Subject Re: Time for Geronimo 2.1.4 release?
Date Tue, 03 Feb 2009 20:51:15 GMT
I was relaying the information second-hand ... so it's very possible I 
got it wrong.

It looks like there is a dependency xBean in OpenEJB ... but it's 3.4.1 
rather than 3.3 (as we have in the branches/2.1).  So, perhaps if we can 
convince OpenEJB 3.0.x to xBean 3.5 we can then make the references 
consistent in our 2.1 branch.


Donald Woods wrote:
> I don't see any dependencies on Xbean in OpenJPA 1.0.x or 1.2.x.  Maybe 
> you're thinking about OpenEJB?
> -Donald
> Joe Bohn wrote:
>> I agree we should get a 2.1.4 release out ... and you certainly have 
>> my vote for release manager!
>> The only thing I would add to the list is to get our xBean references 
>> to a consistent versions.  I noticed this as I was updating 
>> branches/2.1 and trunk to pull in the newly released xBean 3.5.  In 
>> branches/2.1 we have a mix of 3.3 dependencies (finder and reflect) 
>> and 3.5 dependencies (naming).  I've been told that this was due to 
>> OpenJPA dependencies on 3.3.  Now that we are pulling in a new OpenJPA 
>> release we will hopefully be able to update everything to use xBean 3.5.
>> Joe
>> Jarek Gawor wrote:
>>> Hi,
>>> I think it's time for Geronimo 2.1.4 release. We've had a lot of
>>> important fixes since 2.1.3 and we should get them out to our users.
>>> And if we agree, I would also like to volunteer to be a release
>>> manager for this release.
>>> Looking at the current status for 2.1.4 there are still a few things
>>> that we need to do before we can go ahead with the release. I updated
>>> the 

>>> page with some of these items. If there are any open bugs that _need_
>>> to be fixed for 2.1.4 or if I missed anything in that list please just
>>> update that wiki page.
>>> Thanks,
>>> Jarek

View raw message