geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Forrest_Xia <forres...@gmail.com>
Subject Re: [BUILD] branches/2.1: Failed for Revision: 745486
Date Wed, 25 Feb 2009 18:20:37 GMT

Hi Joe,

Thank you for quick response. But my case is a little bit different than
yours. Finally, I also fixed the problem by updating a wrong geronimo
version used in a former sample plugin. 

My case's tricky is, in the plugin build list, a version-wrong-used sample
plugin, which used geronimo 2.1.1, is in front of the ejb one, that cause
maven loading geronimo 2.1.1 jars into classloader, eventually lead to asm
bad method exception.

The lesson learn is we need to keep all artifact version level identical for
a same build group. Any difference might lead unexpected problem.

thanks, 
Forrest

Joe Bohn wrote:
> 
> Hi Forrest,
> 
> Yes, the problem is now resolved.  David Blevins recalled that there 
> were changes necessary in the jndi-names due to a fix that now properly 
> handles the jndi-name overrides in openejb-jar.xml.  So, in branches/2.1 
> rev. 747480 & 747481 he made changes like to use the correct jndi name 
> in the tests:
> 
> -        String jndiName = "ejb/mgmt/MEJBRemoteHome"; // should be 
> "ejb/mgmt/MEJB"
> +        String jndiName = "ejb/mgmt/MEJB";
> 
> Hope that helps,
> Joe
> 
> .
> Forrest_Xia wrote:
>> Hi Joe,
>> 
>> Any solution to this problem? I encountered the same error when building
>> a
>> sample plugin which includes an ejb artifact. 
>> 
>> Thanks,
>> Forrest
>> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/-BUILD--branches-2.1%3A-Failed-for-Revision%3A-745486-tp22080420s134p22208650.html
Sent from the Apache Geronimo - Dev mailing list archive at Nabble.com.


Mime
View raw message