geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Forrest Xia (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-4481) GShell command jaxws/java2ws error: Syntax error, annotations are only available if source level is 5.0
Date Sun, 11 Jan 2009 09:35:59 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-4481?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12662746#action_12662746
] 

Forrest Xia commented on GERONIMO-4481:
---------------------------------------

Jarek, thanks for verification.

We have different OS tried. You use windows, I use Linux. And the jdk version is different,
you use sun jdk 1.5.0_16, I use sun jdk 1.6.0_10.

I also tried a new snapshot on Jan. 10. The same problem happens on linux.

I also tried on Windows XP with sun jdk 1.5.0_16. This time the problem is different, it is
like this:
D:\vm_share\geronimo-tomcat6-javaee5-2.2-SNAPSHOT\bin>cxf-tools.bat java2ws -ver
bose -wsdl -client -server -wrapperbean -ant -o test.wsdl -s d:\temp\java2ws -d
d:\temp\java2ws -classdir d:\temp\java2ws -cp d:\vm_share\G3665FeatureValidation
.jar org.apache.geronimo.test.fixver.g3665.SayHelloWebService
Using GERONIMO_HOME:   D:\vm_share\geronimo-tomcat6-javaee5-2.2-SNAPSHOT
Using GERONIMO_TMPDIR: var\temp
Using JRE_HOME:        C:\Program Files\Java\jdk1.5.0_16\jre
log4j:WARN No appenders could be found for logger (org.apache.geronimo.kernel.re
pository.Maven2Repository).
log4j:WARN Please initialize the log4j system properly.
java2ws -verbose -wsdl -client -server -wrapperbean -ant -o test.wsdl -s d:\temp
\java2ws -d d:\temp\java2ws -classdir d:\temp\java2ws -cp d:\vm_share\G3665Featu
reValidation.jar org.apache.geronimo.test.fixver.g3665.SayHelloWebService
java2ws - Apache CXF 2.1.4-SNAPSHOT

[ERROR] IOException during exec() of compiler "javac". Check your path environme
nt variable.

Seems the class files are not generated.

Before running this command, I set JAVA_HOME and JRE_HOME, actually the cxf-tools.bat|.sh
fould it, but just cannot do correct compilation.

Please help double check this tools in a linux platform. thanks!

Forrest

> GShell command jaxws/java2ws error: Syntax error, annotations are only available if source
level is 5.0
> -------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-4481
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4481
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: webservices
>    Affects Versions: 2.2
>         Environment: java version "1.6.0_10"
> Java(TM) SE Runtime Environment (build 1.6.0_10-b33)
> Java HotSpot(TM) Client VM (build 11.0-b15, mixed mode, sharing)
> ubuntu 8.04.1 LTS
>            Reporter: Forrest Xia
>            Priority: Minor
>         Attachments: G3665FeatureValidation.jar
>
>
> Steps to recurring:
> 1. start 2.2 snapshot server
> 2. enter gshell prompt
> 3. execute command like this:
> <code>
> jaxws/java2ws -wsdl -client -server -wrapperbean -ant -o test.wsdl -s /home/forrestxm/temp/gshell015
-d /home/forrestxm/temp/gshell015 -classdir /home/forrestxm/temp/gshell015 -cp /home/forrestxm/temp/gshell015/G3665FeatureValidation.jar
org.apache.geronimo.test.fixver.g3665.SayHelloWebService
> </code>
> then the errors say "Syntax error, annotations are only available if source level is
5.0". Checked cxf 2.1.3 release, there are similar problems when executing a similar command.
> However, use the generated ant project to compile those generated source code, it's fine.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message