geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "B.J. Reed (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMODEVTOOLS-558) Testsuite not able to find DefaultSelenium class
Date Fri, 16 Jan 2009 15:03:00 GMT
Testsuite not able to find DefaultSelenium class
------------------------------------------------

                 Key: GERONIMODEVTOOLS-558
                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-558
             Project: Geronimo-Devtools
          Issue Type: Sub-task
          Components: eclipse-plugin
    Affects Versions: 2.2.0, 2.1.4
            Reporter: B.J. Reed
            Assignee: Tim McConnell
            Priority: Blocker
             Fix For: 2.2.0, 2.1.4


Running the testsuite from Eclipse, I get a java.lang.NoClassDefFoundError: com/thoughtworks/selenium/DefaultSelenium
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(Unknown Source)
	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:165)
	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:554)
	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:524)
	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:455)
	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass_LockClassLoader(ClasspathManager.java:443)
	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:423)
	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:193)
	at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:368)
	at org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackage.java:33)
	at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:441)
	at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:397)
	at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:385)
	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:87)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClassInternal(Unknown Source)
	at org.apache.geronimo.testsuite.v22.ui.EclipseUITest.installServer(EclipseUITest.java:110)
	at org.apache.geronimo.testsuite.v22.ui.EclipseUITest.testEclipseUI(EclipseUITest.java:58)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at junit.framework.TestCase.runTest(TestCase.java:164)
	at junit.framework.TestCase.runBare(TestCase.java:130)
	at abbot.swt.junit.extensions.SWTTestCase.runBareWrapper(SWTTestCase.java:279)
	at abbot.swt.junit.extensions.SWTTestCase.access$2(SWTTestCase.java:276)
	at abbot.swt.junit.extensions.SWTTestCase$4.execute(SWTTestCase.java:253)
	at abbot.swt.junit.extensions.UserThread.run(UserThread.java:75)

Testsuite runs fine when run from maven.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message