geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <j...@apache.org>
Subject [jira] Closed: (GERONIMO-3148) ActiveMQ Broker config is missing some dependencies
Date Mon, 08 Dec 2008 23:25:44 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-3148?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Jencks closed GERONIMO-3148.
----------------------------------

    Resolution: Duplicate
      Assignee: David Jencks

This is getting fixed in 2.2 as part of the move to activemq 5.2 (GERONIMO-4337)

> ActiveMQ Broker config is missing some dependencies
> ---------------------------------------------------
>
>                 Key: GERONIMO-3148
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-3148
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: ActiveMQ
>    Affects Versions: 2.0-M6
>            Reporter: Kristian Koehler
>            Assignee: David Jencks
>         Attachments: active-mq-broker.patch
>
>
> Hi
> I tried to use an external config file for the embedded ActiveMQ broker. For this scenario
the BrokerServiceGBeanImpl provides an attribute called 'brokerUri' where you can give an
activemq.xml ('spring based') configuration.
> By setting this value ClassNotFound Exceptions are thrown because some spring and xbean
libs are not configured correctly within the ActiveMQ broker configuration.
> The attached patch fixes the dependency problem and a smaller typo within the plan.xml.
> Kristian

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message