geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun" <linsun....@gmail.com>
Subject Re: [DISCUSS] Only Support Java SE 6 with Geronimo 2.2
Date Fri, 07 Nov 2008 15:01:16 GMT
Is it possible for us to support Java SE 5 (with certain known
restrictions) but only certified with Java SE 6?

I think it can be a big usability issue to require users to upgrade to
Java SE 6 in order to use G 2.2.   If we run a survey on our G users
(including committers) I would not be surprised that most of us are
still using Java SE 5.

Using branch 2.1 may not be an option, as some of the
fixes/enhancement are not even avail in branch 2.1.

Lin

On Fri, Nov 7, 2008 at 12:04 AM, Donald Woods <dwoods@apache.org> wrote:
> The time has come to make the hard decision -
>
> Do we only build and certify Geronimo 2.2 on the Sun 1.6.0 JDK and drop
> support for running on Java SE 5?
>
> Pros:
> - Reduce testing effort to one version of Java
> - Allows us to use the JAXB 2.1, JAX-WS 2.1 and wsgen tools in the JDK,
> instead of shipping those jars in our assemblies (and removes some more Sun
> RI from our assemblies)  :-)
> - Keeps us current on the latest Java release
> - All major platforms have a Java SE 6 solution:
>  - Sun provided 1.6.0 for Windows, Solaris, Linux on Intel/AMD
>  - MacOS 10.5.x provides 1.6.0_07
>  - openSUSE 11.0/11.1 users can install Sun 1.6.0_10 from build repos
>  - Ubuntu 7.04 and later users can install Sun 1.6.0 from net repos
>  - Fedora 9/10 comes with OpenJDK 6, but users can install Sun 1.6.0
>  - IBM provides 1.6.0 SR2 for AIX, pLinux, zLinux, zOS, ...
>
> Cons:
> - Users will have to upgrade to Java SE 6 to run Geronimo 2.2
> - Will require us to maintain the 2.1 branch during 2009 for any users who
> want to stay on Java SE 5
>
> I'm for moving to a Java SE 6 only runtime for Geronimo 2.2.
>
>
> -Donald
>

Mime
View raw message