geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "viola.lu (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMODEVTOOLS-531) Security Setting In UI doesn't completely reflect in source mode
Date Tue, 11 Nov 2008 03:49:44 GMT
Security Setting In UI doesn't completely reflect in source mode
----------------------------------------------------------------

                 Key: GERONIMODEVTOOLS-531
                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-531
             Project: Geronimo-Devtools
          Issue Type: Bug
          Components: eclipse-plugin
    Affects Versions: 2.1.3
         Environment: OS:WIndows 2003, Suse
            Reporter: viola.lu
            Assignee: Tim McConnell
            Priority: Minor


Steps:
1.Create a web dynamic project, append its web.xml with below snippnet
<security-role>
  	<role-name>content-admin</role-name>
  </security-role>

2.Open geronimo-web.xml, click "Security" tab, choose Role "content-admin", add a Realm principal,
choose geronimo-admin, input name "admin",domain name "admin", save it.

3.Go to source mode, it just append a snippnet below
<sec:security>
        <sec:role-mappings>
            <sec:role role-name="content-admin">
                <sec:realm-principal class="org.apache.geronimo.security.realm.providers.GeronimoGroupPrincipal"
domain-name="admin" name="admin" realm-name="geronimo-admin"/>
            </sec:role>
        </sec:role-mappings>
    </sec:security>

missing part:
<web:security-realm-name>geronimo-admin</web:security-realm-name>

4.So geronimo-web.xml marks as red with error. i should manally add above missing part to
make it work.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message