geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shawn Jiang (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GERONIMO-4404) ActiveMQ connectors should use ServerHostname from config-substitutions.properties
Date Wed, 12 Nov 2008 09:03:44 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-4404?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Shawn Jiang updated GERONIMO-4404:
----------------------------------

    Attachment: G4404_truck.patch

Since activemq means to be used as standalone server.  it's reasonable to them to amplify
localhost to 0.0.0.0 to make sure the activemq is reachable if the user set the host other
than "127.0.0.1".

If so , we can force the localhost to 127.0.0.1 in geronimo side as a workaround.  This is
the patch to truck code. Please review, thanks.




> ActiveMQ connectors should use ServerHostname from config-substitutions.properties
> ----------------------------------------------------------------------------------
>
>                 Key: GERONIMO-4404
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4404
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: ActiveMQ
>    Affects Versions: 2.1.3
>            Reporter: Donald Woods
>            Priority: Minor
>             Fix For: 2.1.4
>
>         Attachments: G4404_branch21.patch, G4404_truck.patch
>
>
> Ron Staerker reported that if you change ServerHostname in config-substitutions.properties
from 0.0.0.0 to 127.0.0.1, the default ActiveMQ connectors on 61613 and 61616 will still bind
to 0.0.0.0 instead of the new ServerHostname value.  This seems to b caused by several pom.xml
problems, where:
> <config-property-setting name="ServerUrl">tcp://${PlanServerHostname}:${PlanActiveMQPort}</config-property-setting>
> where PlanServerHostname is 0.0.0.0 and not in config-substitutions.properties
> <attribute name="host">#{ServerHostname}</attribute>
> is being substituted in at build time to be 0.0.0.0 instead of putting ${ServerHostname}
in the plans.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message