geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rex Wang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-4405) Postgresql new drives would not be listed in Drive Jars list and download driver list
Date Fri, 14 Nov 2008 02:56:44 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-4405?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12647506#action_12647506
] 

Rex Wang commented on GERONIMO-4405:
------------------------------------

Yes, Lin. I mean the reporter here wanna install a postgreSQL 8.3 jars to geronimo repository,
but after that she can't find that in the jars list of the portlet. 
I think it is not reasonable that we don't allow user to try installing a new jdbc jars to
our server.
So I changed it from 
 <attribute name="dependencyFilterStrings">postgresql/postgresql//jar,postgresql/postgresql-7.3//jar,postgresql/postgresql-7.4//jar,postgresql/postgresql-8.0//jar,postgresql/postgresql-8.1//jar,postgresql/postgresql-8.2//jar</attribute>
to
<attribute name="dependencyFilterStrings">postgresql///jar</attribute>
This can solve her issue and I think it is not conflict with the way we control the tested
jdbc jars. 

> Postgresql new drives would not be listed in Drive Jars list and download driver list
> -------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-4405
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4405
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: databases
>    Affects Versions: 2.1.3
>         Environment: Any platform
>            Reporter: viola.lu
>            Priority: Minor
>         Attachments: GERONIMO-4405.patch
>
>
> Steps:
> 1.login admin console, go to "repository" porlet, install a postgresql jdbc driver 8.3
> 2.Go to "database pool" porlet->create a datasource type postgresql local or XA, click
next.Newly installed driver is not listed in driver jars.
> 3.CLick "download driver" button, just postgresql 8.1.8.2,7.4 is listed, can't choose
8.3.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message