geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ant elder" <>
Subject Re: Tuscany Geronimo integration and the SCA JEE spec
Date Tue, 07 Oct 2008 07:23:01 GMT
On Tue, Oct 7, 2008 at 4:44 AM, Kevan Miller <> wrote:

> On Oct 6, 2008, at 10:17 PM, Kevan Miller wrote:
>> On Oct 3, 2008, at 5:57 AM, ant elder wrote:
>>  I'd like to start spending more time actively working on the Tuscany
>>> Geronimo integration and having that more support the SCA JEE specification
>>> (see: [1]). Here is a rough outline of what i'd like to do:
>>> The goal of this would be to use Geronimo and Tuscany to create an
>>> SCA-enabled Java EE runtime, which from the SCA JEE specification means "a
>>> Java EE runtime that supports deployment and execution of SCA-enhanced Java
>>> EE applications as well as SCA-enhanced Java EE modules."
>>> We already have a start of that with the old Tuscany Geronimo Plugin [2]
>>> and there's another wiki page thats started to be used to capture some
>>> requirements at [3]. Currently the old TGP has got out of date and doesn't
>>> work with any current releases of Geronimo or Tuscany so the first thing to
>>> do is to get a basic plugin going again and then gradually add functionality
>>> to it so it does things like:
>> I took a look at Vamsi's recent updates to the Tuscany plugin and fixed a
>> minor version dependency problem. I can now build, but installation fails
>> with a NullPointerException:
>> Caused by: java.lang.NullPointerException
>>        at
>>        at
>>        at Method)
>>        at
>> The NullPointerException is caused because WSBindingDefinitionsProvider
>> (line 46) is looking for a URLArtifactProcessor for the
>> interface. However, there
>> isn't a processor defined for this interface. Thus the
>> NullPointerException...
>> Not sure what should be happening, here...
> K. The plugin needed a new dependency for tuscany-definitions-xml (thanks
> for the info Luciano). Plugin builds and installs for me -- I haven't tried
> to use it... I do see one WARNING:
> WARNING: Exception starting module
> :org/apache/tuscany/sca/databinding/jaxb/XMLAdapterExtensionPoint
> --kevan

This still doesn't work for me, to install it do you do anything more than
what is described in the plugin README.txt (

The latest plugin code (r702337) builds ok but trying to use it with a fresh
install of following the steps in the
README.txt fails at step "3. Deploy plugin using the command..." with:

C:\Geronimo\geronimo-tomcat6-javaee5-2.1.3\bin>deploy.bat install-plugin
Using GERONIMO_BASE:   C:\Geronimo\bla\geronimo-tomcat6-javaee5-2.1.3
Using GERONIMO_HOME:   C:\Geronimo\bla\geronimo-tomcat6-javaee5-2.1.3
Using GERONIMO_TMPDIR: var\temp
Using JRE_HOME:        \Java\jdk1.5.0_15\jre
Username: system
Password: *******
Checking for status every 1000ms:
Downloading org.apache.geronimo.plugins/geronimo-tuscany/1.0-SNAPSHOT/jar
Installation FAILED: Could not find
org.apache.geronimo.plugins/geronimo-tuscany/1.0-SNAPSHOT/jar in any repo

Any hints what I might be doing wrong?


View raw message