geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy" <c1vams...@gmail.com>
Subject Is the PlanCreator portlet from trunk working?
Date Fri, 17 Oct 2008 17:12:36 GMT
I tried using the Plan Creator portlet in the server built from trunk and
ended up with the following exceptions:

*description* *The server encountered an internal error () that prevented it
from fulfilling this request.*

*exception*

javax.servlet.ServletException: javax.portlet.PortletException
	org.apache.pluto.driver.PortalDriverServlet.doGet(PortalDriverServlet.java:125)
	org.apache.pluto.driver.PortalDriverServlet.doPost(PortalDriverServlet.java:167)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:713)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:806)

*root cause*

javax.portlet.PortletException
	org.apache.pluto.core.DefaultPortletInvokerService.invoke(DefaultPortletInvokerService.java:191)
	org.apache.pluto.core.DefaultPortletInvokerService.action(DefaultPortletInvokerService.java:85)
	org.apache.pluto.core.PortletContainerImpl.doAction(PortletContainerImpl.java:219)
	org.apache.pluto.driver.PortalDriverServlet.doGet(PortalDriverServlet.java:121)
	org.apache.pluto.driver.PortalDriverServlet.doPost(PortalDriverServlet.java:167)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:713)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:806)

*root cause*

java.lang.NoClassDefFoundError:
org/apache/geronimo/deployment/plugin/jmx/JMXDeploymentManager
	org.apache.geronimo.console.configcreator.JSR88_Util.createApplicationInfo(JSR88_Util.java:71)
	org.apache.geronimo.console.configcreator.GetArchiveHandler.actionAfterView(GetArchiveHandler.java:70)
	org.apache.geronimo.console.MultiPagePortlet.processAction(MultiPagePortlet.java:114)
	org.apache.pluto.core.PortletServlet.dispatch(PortletServlet.java:218)
	org.apache.pluto.core.PortletServlet.doPost(PortletServlet.java:145)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:713)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
	org.apache.pluto.core.DefaultPortletInvokerService.invoke(DefaultPortletInvokerService.java:167)
	org.apache.pluto.core.DefaultPortletInvokerService.action(DefaultPortletInvokerService.java:85)
	org.apache.pluto.core.PortletContainerImpl.doAction(PortletContainerImpl.java:219)
	org.apache.pluto.driver.PortalDriverServlet.doGet(PortalDriverServlet.java:121)
	org.apache.pluto.driver.PortalDriverServlet.doPost(PortalDriverServlet.java:167)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:713)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:806)

*note* *The full stack trace of the root cause is available in the Apache
Tomcat/6.0.18 logs.*
Does anyone know if this portlet is working?

++Vamsi

Mime
View raw message