geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Donald Woods (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-511) Provide zip download of Geronimo Eclipse Plugin complete with requisites
Date Mon, 08 Sep 2008 13:18:46 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-511?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12629150#action_12629150
] 

Donald Woods commented on GERONIMODEVTOOLS-511:
-----------------------------------------------

This JIRA does not make sense.  If you're trying to install a 1.0 Server adapter, then you
need to install the version of Eclipse that it is supported on first.  We have no plans to
release any new updates to the 1.x servers or tooling.

Also, I'd have to vote -1 to the request to provide a GEP+Eclipse bundle for any release.
 We should not be providing custom versions of Eclipse images or providing the Eclipse Java
EE bundle from the ASF servers.  If there are installation problems with GEP 2.1.x on Eclipse
3.3 or 3.4, then please open a JIRA with workspace logs and exact steps to reproduce it, so
we can resolve this once and for all (but I think Eclipse 3.4 is at fault for some problems
right now, which hopefully the 3.4.1 release will fix.)




> Provide zip download of Geronimo Eclipse Plugin complete with requisites
> ------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-511
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-511
>             Project: Geronimo-Devtools
>          Issue Type: Wish
>          Components: eclipse-plugin
>    Affects Versions: 2.1.2
>            Reporter: J├╝rgen Weber
>            Assignee: Tim McConnell
>
> Please provide a zip / tar.gz download of Geronimo Eclipse Plugin complete with all requisites,
inclusive a stripped-down Eclipse itself.
> The zip should not contain eclipse as root folder but rather eclipseGeronimo to not overwrite
the default Eclipse installation.
> The download options described in http://geronimo.apache.org/development-tools.html
> require that WTP and some more are installed. Installing WTP is error-prone, as it has
lots of dependencies you need in the right version. 
> Installing via Eclipse-Help-Software Updates does not work either as the Update manager
is not smart enough to install requisites:
> Geronimo v1.0 Server Adapter (2.0.0) requires feature "org.eclipse.jst (2.0.0)", or compatible
> The given ant script does not work behind our firewall, and I am not keen on figuring
out how the firewall options of ant work.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message