geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Weber (JIRA) <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-511) Provide zip download of Geronimo Eclipse Plugin complete with requisites
Date Wed, 10 Sep 2008 17:39:44 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-511?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12629877#action_12629877
] 

Jürgen Weber commented on GERONIMODEVTOOLS-511:
-----------------------------------------------

OK, I recant, installing the plugin is easy. 
If you know how. I was mislead by the documentation.

The page http://geronimo.apache.org/development-tools.html onto which you are lead by the
news box on the Geronimo main page, describes first the really hard ways.

The easy way is way down under Additional Information
-> Geronimo Eclipse Plugin Installation Instructions

The linked page (http://geronimo.apache.org/geronimo-eclipse-plugin-installation-instructions.html)
describes the easy way:
Install Geronimo Eclipse Plugin Using WTP

Unfortunately, this page lacks two important points:

a) WTP is Eclipse IDE for Java EE Developers from 
http://www.eclipse.org/downloads/

b) The "download additional server adapters" only works if a new remote site pointing to http://www.apache.org/dist/geronimo/eclipse/updates/
was created before. If not, the Geronimo Servers are not found.

So, if the docs are fixed to include setting up the new remote site, installing the Geronimo
plugin is almost as easy as installing Directory Studio.

Still easier would only be a complete zip download ...

> Provide zip download of Geronimo Eclipse Plugin complete with requisites
> ------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-511
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-511
>             Project: Geronimo-Devtools
>          Issue Type: Wish
>          Components: eclipse-plugin
>    Affects Versions: 2.1.2
>            Reporter: Jürgen Weber
>            Assignee: Tim McConnell
>
> Please provide a zip / tar.gz download of Geronimo Eclipse Plugin complete with all requisites,
inclusive a stripped-down Eclipse itself.
> The zip should not contain eclipse as root folder but rather eclipseGeronimo to not overwrite
the default Eclipse installation.
> The download options described in http://geronimo.apache.org/development-tools.html
> require that WTP and some more are installed. Installing WTP is error-prone, as it has
lots of dependencies you need in the right version. 
> Installing via Eclipse-Help-Software Updates does not work either as the Update manager
is not smart enough to install requisites:
> Geronimo v1.0 Server Adapter (2.0.0) requires feature "org.eclipse.jst (2.0.0)", or compatible
> The given ant script does not work behind our firewall, and I am not keen on figuring
out how the firewall options of ant work.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message