geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Kirby (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (GERONIMODEVTOOLS-332) GEP should be made to work with the Trunk version of the Geronimo Server
Date Tue, 12 Aug 2008 03:34:45 GMT

     [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-332?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ted Kirby reopened GERONIMODEVTOOLS-332:
----------------------------------------


Consider defining a v2.1 server, but providing a v2.0 server installation directory.  I think
this should be an error, and the user should not be allowed to click the next button.  For
the 1.6 JRE case, a warning seems proper, but not in this case.  We need to fix the code to
properly handle the SNAPSHOT case.  It seems for this version checking, maybe we only care
about n.n, or maybe ^\d+(\.\d+)*.  Apply that pattern to the runtime version, and see if the
detected Version starts with that string.

> GEP should be made to work with the Trunk version of the Geronimo Server
> ------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-332
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-332
>             Project: Geronimo-Devtools
>          Issue Type: New Feature
>          Components: eclipse-plugin
>    Affects Versions: 2.1.3
>            Reporter: Tim McConnell
>            Assignee: Tim McConnell
>             Fix For: 2.1.2
>
>
> When trying to install the Trunk version of the Geronimo server, which is now version
2.2-SHAPSHOT, the GEP does not recognize as a 2.x server and presents the "Invalid version
detected", and prevents adding the server.....

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message