geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: Unable to download G runtime from Eclipse
Date Thu, 07 Aug 2008 15:00:53 GMT
Hi Ashish, it only worked for me the other day because I had first downloaded the 
GEP plugin via the Update Manager. It won't work correctly if you. Your scenario 
is only slightly different than the one we warned against in the following 
documentation. I investigated this problem back in 2.1.0 and have a very long 
writeup for why it won't work (which I'll try to find again). But for now, if you 
plan to use the "Download and Install" feature of the GEP just ensure you use the 
Update Manager first to download the plugin. Thanks.

---> 
http://geronimo.apache.org/developing-the-geronimo-eclipse-plugin-in-eclipse.html


Ashish Jain wrote:
> Hi Ted,
> Thanks for your reply! Yes you are correct it works fine once you have 
> installed it through Eclipse update manager.
> Somehow it worked for Tim day before yesterday. May be he can suggest 
> something.
> 
> Thanks
> Ashish
> 
> On Thu, Aug 7, 2008 at 7:46 PM, Ted Kirby <ted.kirby@gmail.com 
> <mailto:ted.kirby@gmail.com>> wrote:
> 
>     Download and Install is very touchy.  I have mostly never been able to
>     get it to work when launching the plugin from eclipse, as you are
>     doing.  It worked for me for a little while when I first started
>     working with Ganymede, but then stopped.  I've pretty much had to give
>     up on developing it this way. :-(  So, you'll have to build the
>     plugin, and install it via the eclipse update manager.   :-(
> 
>     Ted Kirby
> 
>     On Thu, Aug 7, 2008 at 8:42 AM, Ashish Jain <ashjain2@gmail.com
>     <mailto:ashjain2@gmail.com>> wrote:
>      > HI,
>      > Trying to download the latest G V2.1.2 from my Eclipse workspace.
>     These are
>      > the steps I follow
>      >
>      > 1) Downloaded the latest GEP source.
>      > 2) Build was successful.
>      > 3) Started another instance of Eclipse from my Eclipse workspace.
>      > 4) Adding a server runtime.
>      > 5) Clicked on Download and Install.
>      > 6) Got the license panel. Later I hit the following error.
>      >
>      > org.eclipse.wst.server.core SEVERE    07/08/08 17:57.57.531 Error
>     installing
>      > feature
>      > org.eclipse.core.runtime.CoreException: Could not download and
>     install
>      > update feature.
>      >     at
>      >
>     org.eclipse.wst.server.core.internal.InstallableRuntime.install(InstallableRuntime.java:260)
>      >     at
>      >
>     org.apache.geronimo.st.ui.internal.GeronimoRuntimeWizardFragment$1$2.run(GeronimoRuntimeWizardFragment.java:247)
>      >     at
>      >
>     org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
>      > org.apache.geronimo.st.ui:  Error installing runtime
>      > org.eclipse.core.runtime.CoreException: Error occurred installing
>     server:
>      > Could not download and install update feature.
>      >     at
>      >
>     org.eclipse.wst.server.core.internal.InstallableRuntime.install(InstallableRuntime.java:271)
>      >     at
>      >
>     org.apache.geronimo.st.ui.internal.GeronimoRuntimeWizardFragment$1$2.run(GeronimoRuntimeWizardFragment.java:247)
>      >     at
>      >
>     org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
>      > Caused by: org.eclipse.core.runtime.CoreException: Could not
>     download and
>      > install update feature.
>      >     at
>      >
>     org.eclipse.wst.server.core.internal.InstallableRuntime.install(InstallableRuntime.java:260)
>      >     ... 2 more
>      >
>      > In my eclipse workspace .metadata/.log I have the followng error
>      >
>      > !ENTRY org.eclipse.update.configurator 4 0 2008-08-07 17:56:45.406
>      > !MESSAGE Unable to find feature.xml in directory:
>      > C:\gep_new\trunk\features\.svn
>      >
>      > !ENTRY org.eclipse.update.configurator 4 0 2008-08-07 17:56:45.406
>      > !MESSAGE Unable to find feature.xml in directory:
>      > C:\gep_new\trunk\features\bigG.gif
>      >
>      > !ENTRY org.eclipse.update.configurator 4 0 2008-08-07 17:56:45.406
>      > !MESSAGE Unable to find feature.xml in directory:
>      > C:\gep_new\trunk\features\pom.xml
>      >
>      > !ENTRY org.eclipse.update.configurator 4 0 2008-08-07 17:56:45.421
>      > !MESSAGE Unable to find feature.xml in directory:
>      > C:\gep_new\trunk\features\Thumbs.db
>      >
>      > I also modified
>      >
>     C:\gep_new\trunk\plugins\org.apache.geronimo.st.v21.core\plugin.xml as
>      > follows. This is the new staging site created by Tim.
>      >
>      > <extension point="org.eclipse.wst.server.core.installableRuntimes">
>      >         <installableRuntime
>     id="org.apache.geronimo.runtime.tomcat.21"
>      >             featureVersion="2.1.2"
>      >             featureId="org.apache.geronimo.server.tomcat.v21.feature"
>      >
>      >
>     featureSite="http://people.apache.org/~mcconne/releases/2.1.2/RC1/staging_site/eclipse/updates/
>     <http://people.apache.org/%7Emcconne/releases/2.1.2/RC1/staging_site/eclipse/updates/>"
>      >             path="geronimo-tomcat6-javaee5-2.1.2.zip">
>      >         </installableRuntime>
>      >         <installableRuntime id="org.apache.geronimo.runtime.jetty.21"
>      >             featureVersion="2.1.2"
>      >             featureId="org.apache.geronimo.server.jetty.v21.feature"
>      >
>      >
>     featureSite="http://people.apache.org/~mcconne/releases/2.1.2/RC1/staging_site/eclipse/updates/
>     <http://people.apache.org/%7Emcconne/releases/2.1.2/RC1/staging_site/eclipse/updates/>"
>      >             path="geronimo-jetty6-javaee5-2.1.2.zip">
>      >         </installableRuntime>
>      >     </extension>
>      >
>      >  I also created a new remote site in my Eclipse workspace which
>     is same as
>      > the staging
>      >
>     site(http://people.apache.org/~mcconne/releases/2.1.2/RC1/staging_site/eclipse/updates/
>     <http://people.apache.org/%7Emcconne/releases/2.1.2/RC1/staging_site/eclipse/updates/>)
>      >
>      > I am using Eclipse Ganymede however I hit the same error when I
>     use Europa.
>      > I am using sun java 1.5.0_13
>      >
>      > This error is somehow stopping me to work on GERONIMODEVTOOLS-325
>     wherein I
>      > need to recreate a error as pointed by Tim
>      > Please help!!!
>      >
>      > Thanks
>      > Ashish
>      >
>      >
> 
> 

-- 
Thanks,
Tim McConnell

Mime
View raw message