geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Kirby" <ted.ki...@gmail.com>
Subject Re: GEP and Java6
Date Thu, 07 Aug 2008 16:00:50 GMT
D'Oh!  Thanks Tim.  What does "supported" mean, anyway?  Given that
users are hitting this problem, maybe we need to be more visible in
our warnings.  Let's see where we get to with this Java 6 JIRA in the
next day or two, and adjust our documentation and possibly code
accordingly.

Thanks,
Ted Kirby

On Thu, Aug 7, 2008 at 11:40 AM, Tim McConnell <tim.mcconne@gmail.com> wrote:
> Hi Ted, good ideas. Actually the GEP already has that type of warning
> message.....
>
> jvmWarning={0} is currently only certified on a 1.5 JVM. Use of any other
> version is not currently supported.
>
> Also, I've opened a task-list JIRA for Java 6 specific problems as you
> suggest. Could you subtasks for the problem(s) you already know about ??
> Thanks
>
> https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-466
>
>
> Ted Kirby wrote:
>>
>> I have seen a number of problems with particularly new users running
>> Geronimo with GEP, and having problems.  They switch to Java 5, and
>> things work for them.  For GEP 2.1.2, which we want to get out ASAP
>> now that G2.1.2 is released, I think GEP should detect Java 6 when a
>> Geronimo server is defined, and warn the user of problems, and suggest
>> they use Java 5.  I am not clear on the Geronimo server's position on
>> Java6.  My understanding is that Geronimo is certified on Java 5, and
>> will run on Java 6.  We'll want GEP to support/work on Java6 ASAP.
>> Perhaps we should have a task-list JIRA for Java 6 issues.
>>
>> Ted Kirby
>>
>
> --
> Thanks,
> Tim McConnell
>

Mime
View raw message