geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Kirby (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-508) Geronimo v1.1 server adapter of GEP 2.0.0 could not work properly when co-existing with Geronimo v2.1 Server adapter of GEP 2.1.2 in Europa winter
Date Fri, 29 Aug 2008 13:49:44 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-508?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12626971#action_12626971
] 

Ted Kirby commented on GERONIMODEVTOOLS-508:
--------------------------------------------

I would argue that the scenario is not valid.  We have the notion in GEP of doing migration
from the previous release to the current release.  For GEP 2.1.1, we switched from EMF to
JAXB.  It would have taken a lot more work to get the JAXB implementation to work with 1.1.
 So, if you want to work with 1.1, use GEP 2.0.x.  There, you can migrate from 1.1 to 2.0.
 Then, you can use GEP 2.1.1+ to migrate from 2.0 to 2.1+.  Also, I don't think anyone has
tried running GEP 2.0.x in Europa Winter, especially the 1.1 support.  I also think our GEP
doc is lacking here.  I cannot find the doc for GEP 2.0.x at the moment to see what its pre-reqs
are, but I think they are for a pre-Europa Winter release.

> Geronimo v1.1 server adapter of GEP 2.0.0 could not work properly when co-existing with
Geronimo v2.1 Server adapter of GEP 2.1.2 in Europa winter
> --------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-508
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-508
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 2.1.2
>         Environment: OS: Windows 2008
> JDK: IBM SDK 5 sr8a
> eclipse: Europa Winter
>            Reporter: Forrest Xia
>            Assignee: Tim McConnell
>            Priority: Minor
>         Attachments: logs.zip
>
>
> Steps:
> 1. Unzip Europa winter
> 2. Install Geronimo v1.1. server adapter v2.0.0 firstly through "Download additional
server adapter"
> 3. Define a server runtime and try to start geronimo 1.1, it's ok
> 4. Install Geronimo v2.1 server adapter v2.1.2 secondly through "Download additional
server adapter"
> 5. Define a server runtime and try to start geronimo v2.1.1, it's fine as well
> 6. Try to define a second geronimo v1.1 server runtime, this time there is no way to
configure runtime installation directory, so no way to define geronimo v1.1 server runtime
after installed geronimo v2.1 server adapter of GEP 2.1.2
> Symptom analysis: the problem means if you want to work with two geronimo versions in
the same time, you must follow the order described as above, otherwise you won't be able to
work on geronimo v1.1 and geronimo v2.x in the same eclipse.
> I'm not sure if this is a valid usage scenario, but I think there might be cases that
user want to work on two different geronimo release in parallel, for example, they are doing
application migration debug and they need to work on two server adapters in the same eclipse.
So I report it :)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message