geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "B.J. Reed (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GERONIMODEVTOOLS-465) The 'Eclipse-LazyStart' header is deprecated, use 'Bundle-ActivationPolicy'
Date Mon, 25 Aug 2008 19:19:44 GMT

     [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-465?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

B.J. Reed updated GERONIMODEVTOOLS-465:
---------------------------------------

    Attachment: GERONIMODEVTOOLS-465.patch

Searched through the GEP plugins, found about 8 places with the deprecated line.  This patch
should resolve those warnings.

> The 'Eclipse-LazyStart' header is deprecated, use 'Bundle-ActivationPolicy'
> ---------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-465
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-465
>             Project: Geronimo-Devtools
>          Issue Type: Improvement
>          Components: eclipse-plugin
>    Affects Versions: 2.1.2
>            Reporter: Jacek Laskowski
>            Assignee: Tim McConnell
>         Attachments: GERONIMODEVTOOLS-465.patch
>
>
> MANIFEST.MF from org.apache.geronimo.st.core plugin (and possibly others) uses Eclipse-LazyStart
which is deprecated and OSGi's 'Bundle-ActivationPolicy' is recommended.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message