geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashish Jain" <ashja...@gmail.com>
Subject Re: [VOTE] Release Geronimo Eclipse Plugin 2.1.2 (RC2)
Date Fri, 22 Aug 2008 09:33:27 GMT
Sorry for the replying after closing the deadline. I was Out on vacation and
got time to read this now. Not sure if the section on ANT section is still
required in
http://people.apache.org/~mcconne/releases/2.1.2/RC2/Geronimo_Eclipse_Plugin_2.1.2_Instructions-RC2.txt.
As we are having only one dependency that is *IDE FOR JAVA EE Developers. *



*you can use the ant script (that is based on the one used to build the GEP)
that will download and unzip everything for you. You can get the ant
script here:

    http://people.apache.org/~mcconne/releases/2.1.2/RC2/build.xml

After you download the ant script somewhere (preferably in a temp subdirectory)
you can just invoke it for your specific platform using one of these three
commands:

    > ant win32
    > ant linux
    > ant macos

*

Initial releaes however had so many dependencies and it was worthwhile
having a ant script to download all of these

*Eclipse 3.3.1 (Eclipse Classic package of Europa distribution), which is
platform specific
Web Tools Platform (WTP) 2.0.1
Data Tools Platform (DTP) 1.5.1
Eclipse Modeling Framework (EMF) 2.3.1
Graphical Editing Framework (GEF) 3.3.1*

Thanks
Ashish



On Fri, Aug 22, 2008 at 7:06 AM, Lin Sun <linsun.unc@gmail.com> wrote:

> Hi Ted, I agree - we should start a different thread on this.  My
> understanding is that vote thread is for vote only.
>
> Lin
>
> On Thu, Aug 21, 2008 at 5:23 PM, Ted Kirby <ted.kirby@gmail.com> wrote:
> > On Wed, Aug 20, 2008 at 9:56 PM, Lin Sun <linsun.unc@gmail.com> wrote:
> >> +1.  Tested with Eclipse 3.4.
> >>
> >> I did notice one prob.  I installed the Geronimo WTP server adapter
> >> for 2.1.2 first via update site.  Then I went back to Eclipse update
> >> manager to select Apache Geronimo Runtimes, but the Install button is
> >> greyed out.  Does this mean we don't allow users to install Geronimo
> >> runtimes from update manager now?   If so, we should take it off the
> >> list.  I remember we had discussions on not allowing users to download
> >> and install geronimo server from GEP, but don't recall any discussion
> >> on taking it off eclipse update manager.
> >
> > The button is not greyed out with Europa (3.3.2).  We removed the
> > server/runtime features from GEP 2.1.2.  But, they still exist for
> > previous versions of GEP.  I view the issue you raise as a separate
> > question, and it is tricky.  The older versions have the "Download and
> > Install" button on them, and will expect to download the servers from
> > these runtime features.   So, if we remove the server runtimes, that
> > button will not work.  Should we discuss which versions of GEP and
> > server runtimes we want to leave out on our eclipse update site
> > http://www.apache.org/dist/geronimo/eclipse/updates/ ?
> >
> > In any case, I don't think this discussion should affect our vote on
> > and release of GEP 2.1.2.
> >
> > Ted
> >
> >> Lin
> >>
> >> On Wed, Aug 20, 2008 at 9:15 PM, YunFeng Ma <yunfeng_ma@yahoo.com>
> wrote:
> >>> +1
> >>>
> >>> -- YunFeng
> >>>
> >>> Tim McConnell wrote:
> >>>
> >>> Hi everyone, Please review and vote on the maintenance release of the
> >>> Geronimo Eclipse Plugin 2.1.2 RC2.
> >>>
> >>> The deployable zip file is here:
> >>>
> >>> ---->
> >>>
> http://people.apache.org/~mcconne/releases/2.1.2/RC2/geronimo-eclipse-plugin-2.1.2-deployable.zip<http://people.apache.org/%7Emcconne/releases/2.1.2/RC2/geronimo-eclipse-plugin-2.1.2-deployable.zip>
> >>>
> >>> The update site zip file is here:
> >>>
> >>> ---->
> >>>
> http://people.apache.org/~mcconne/releases/2.1.2/RC2/geronimo-eclipse-plugin-2.1.2-updatesite.zip<http://people.apache.org/%7Emcconne/releases/2.1.2/RC2/geronimo-eclipse-plugin-2.1.2-updatesite.zip>
> >>>
> >>> The current svn location is here (revision number 686865):
> >>>
> >>> ---->
> >>>
> https://svn.apache.org/repos/asf/geronimo/devtools/eclipse-plugin/branches/2.1.2
> >>>
> >>> The future svn location will be here (when approved):
> >>>
> >>> ---->
> >>>
> https://svn.apache.org/repos/asf/geronimo/devtools/eclipse-plugin/tags/2.1.2
> >>>
> >>> If you would like to review and/or comment on the release notes, they
> are
> >>> here:
> >>>
> >>> ---->
> >>>
> http://people.apache.org/~mcconne/releases/2.1.2/RC2/PLUGIN_RELEASE-NOTES-2.1.2.txt<http://people.apache.org/%7Emcconne/releases/2.1.2/RC2/PLUGIN_RELEASE-NOTES-2.1.2.txt>
> >>>
> >>> There is a rudimentary set of install instructions available at the URL
> >>> below that will hopefully describe the necessary prereq(s) and steps
> >>> required to install and run the GEP:
> >>>
> >>> ---->
> >>>
> http://people.apache.org/~mcconne/releases/2.1.2/RC2/Geronimo_Eclipse_Plugin_2.1.2_Instructions-RC2.txt<http://people.apache.org/%7Emcconne/releases/2.1.2/RC2/Geronimo_Eclipse_Plugin_2.1.2_Instructions-RC2.txt>
> >>>
> >>> In an effort to get more people to review and vote I'd recommend going
> >>> through this quick but useful tutorial demonstrating some of the
> >>> capabilities of the GEP:
> >>>
> >>> ---->
> >>>
> http://cwiki.apache.org/GMOxDOC21/5-minute-tutorial-on-enterprise-application-development-with-eclipse-and-geronimo.html
> >>>
> >>> Additionally, there is an ant build.xml file that can be used to
> download
> >>> the prereq(s) for the GEP. It is documented in the instructions.
> >>> Finally, I've created a Staging Site that can used to test the update
> >>> manager functions (i.e., p2 in Ganymede) of Eclipse for downloading the
> GEP
> >>> itself. This is also documented in the instructions. Please let me know
> if
> >>> there are any questions and/or problems.
> >>>
> >>> The vote is open for 72 hours and will conclude on Thursday (8/21) at
> 6:30
> >>> PM ET.
> >>>
> >>> [ ] +1  Release Geronimo Eclipse Plugin 2.1.2
> >>> [ ] +0  No opinion
> >>> [ ] -1  Don't release Geronimo Eclipse Plugin 2.1.2
> >>>
> >>>
> >>>
> >>
> >
>

Mime
View raw message