geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashish Jain" <ashja...@gmail.com>
Subject Re: GEP Build Error for revision 683248
Date Wed, 06 Aug 2008 19:49:32 GMT
Joe, thanks for your response. However I hit another error

*[INFO] Executing tasks
    [unzip] Expanding:
C:\m2repo\org\apache\geronimo\assemblies\geronimo-tomcat6
-javaee5\2.1.2-SNAPSHOT\geronimo-tomcat6-javaee5-2.1.2-SNAPSHOT-bin.zip into
C:\
gep_new\trunk\testsuite\launcher
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error executing ant tasks

Embedded error: Error while expanding
C:\m2repo\org\apache\geronimo\assemblies\g
eronimo-tomcat6-javaee5\2.1.2-SNAPSHOT\geronimo-tomcat6-javaee5-2.1.2-SNAPSHOT-b
in.zip
C:\m2repo\org\apache\geronimo\assemblies\geronimo-tomcat6-javaee5\2.1.2-SNAPSHOT
\geronimo-tomcat6-javaee5-2.1.2-SNAPSHOT-bin.zip (The system cannot find the
pat
h specified)*

As G 2.1.2 is released so snapshot may no longer be available.Attaching a
patch for it. Please see if it can be applied to trunk.

Thanks
Ashish

On Wed, Aug 6, 2008 at 10:50 PM, Joe Bohn <joe.bohn@earthlink.net> wrote:

> That's the version of pluto that we have checked into out svn repo in
> trunk.  If you aren't planning to build trunk the easiest thing to do is to
> just cd into the repository directory of server/trunk and mvn install.  This
> will add all of the checked in artifacts into your local m2 repo.
>
> Joe
>
>
>
> Ashish Jain wrote:
>
>> Hi,
>> I am getting a missing dependency error while trying to build GEP. Any
>> suggestions on getting this artifacts rather than manually downloading it my
>> m2repo.
>>
>> [INFO]
>> -----------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> -----------------------------------------------------------------------
>> [INFO] Failed to resolve artifact.
>>
>> Missing:
>> ----------
>> 1) org.apache.pluto:pluto-taglib:jar:1.1.6-G643117
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-t
>> lib \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-tagli
>> \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.plugins:console-tomcat:car:2.1.2
>>        4) org.apache.geronimo.plugins:pluto-support:car:2.1.2
>>        5) org.apache.pluto:pluto-taglib:jar:1.1.6-G643117
>>
>> 2) org.apache.pluto:pluto-descriptor-impl:jar:1.1.6-G643117
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-d
>> criptor-impl \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-descr
>> tor-impl \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.plugins:console-tomcat:car:2.1.2
>>        4) org.apache.geronimo.plugins:pluto-support:car:2.1.2
>>        5) org.apache.pluto:pluto-descriptor-impl:jar:1.1.6-G643117
>>
>> 3) org.apache.tomcat:jasper:jar:6.0.16-G652117
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=org.apache.tomcat
>> -DartifactId=jasper
>>
>>          -Dversion=6.0.16-G652117 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=org.apache.tomcat -DartifactId=jasper
>> \
>>          -Dversion=6.0.16-G652117 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.configs:jasper:car:2.1.2
>>        4) org.apache.tomcat:jasper:jar:6.0.16-G652117
>>
>> 4) org.apache.tomcat:catalina:jar:6.0.16-G652117
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=org.apache.tomcat
>> -DartifactId=catali
>>  \
>>          -Dversion=6.0.16-G652117 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=org.apache.tomcat
>> -DartifactId=catalina \
>>          -Dversion=6.0.16-G652117 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.configs:tomcat6:car:2.1.2
>>        4) org.apache.tomcat:catalina:jar:6.0.16-G652117
>>
>> 5) juddi:juddi:jar:0.9rc4
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=juddi -DartifactId=juddi \
>>          -Dversion=0.9rc4 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=juddi -DartifactId=juddi \
>>          -Dversion=0.9rc4 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.configs:uddi-tomcat:car:2.1.2
>>        4) juddi:juddi:jar:0.9rc4
>>
>> 6) org.apache.pluto:pluto-descriptor-api:jar:1.1.6-G643117
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-d
>> criptor-api \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-descr
>> tor-api \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.plugins:console-tomcat:car:2.1.2
>>        4) org.apache.geronimo.plugins:pluto-support:car:2.1.2
>>        5) org.apache.pluto:pluto-descriptor-api:jar:1.1.6-G643117
>>
>> 7) org.apache.pluto:pluto-portal-driver-impl:jar:1.1.6-G643117
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-p
>> tal-driver-impl \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-porta
>> driver-impl \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.plugins:console-tomcat:car:2.1.2
>>        4) org.apache.geronimo.plugins:pluto-support:car:2.1.2
>>        5) org.apache.pluto:pluto-portal-driver-impl:jar:1.1.6-G643117
>>
>> 8) org.apache.pluto:pluto-portal-driver:jar:1.1.6-G643117
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-p
>> tal-driver \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-porta
>> driver \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.plugins:console-tomcat:car:2.1.2
>>        4) org.apache.geronimo.plugins:pluto-support:car:2.1.2
>>        5) org.apache.pluto:pluto-portal-driver:jar:1.1.6-G643117
>>
>> 9) org.apache.pluto:pluto-container:jar:1.1.6-G643117
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>      mvn install:install-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-c
>> tainer \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file
>> there:
>>    mvn deploy:deploy-file -DgroupId=org.apache.pluto
>> -DartifactId=pluto-conta
>> er \
>>          -Dversion=1.1.6-G643117 -Dpackaging=jar -Dfile=/path/to/file \
>>           -Durl=[url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>        1) org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>        2)
>> org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1
>>
>>        3) org.apache.geronimo.plugins:console-tomcat:car:2.1.2
>>        4) org.apache.geronimo.plugins:pluto-support:car:2.1.2
>>        5) org.apache.pluto:pluto-container:jar:1.1.6-G643117
>>
>> ----------
>> 9 required artifacts are missing.
>>
>> for artifact:
>>  org.apache.geronimo.devtools:testsuite-eclipse:pom:2.1.2
>>
>> from the specified remote repositories:
>>  central (http://repo1.maven.org/maven2),
>>  java.net <http://java.net> (http://download.java.net/maven/1/),
>>  apache.incubator (
>> http://people.apache.org/repo/m2-incubating-repository/),
>>  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
>>  apache-snapshots (http://people.apache.org/repo/m2-snapshot-repository),
>>  codehaus-snapshots (http://snapshots.repository.codehaus.org)
>>
>> Thanks
>> Ashish
>>
>
>

Mime
View raw message