geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Kirby (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-501) Adding server in eclipse suggests ""Apache Geronio V2.1 is currently only certified on a 1.5 JVM. Use of any other version is not currently supported."
Date Sun, 24 Aug 2008 16:25:44 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-501?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12625180#action_12625180
] 

Ted Kirby commented on GERONIMODEVTOOLS-501:
--------------------------------------------

I like the first sentence of the warning message: "Apache Geronimo V2.1 is currently only
certified on a 1.5 JVM."  As I have noted elsewhere, I do not like the second sentence, particularly
the "is not currently supported" part.  It would be nice if we had some sort of Geronimo and
GEP "supported" page, where we listed recommended and compatible platforms, and/or statements
about various java levels, and perhaps java versions/vendors.  The message could then reference
that page.  Here, I presume Java 1.4 or lower does not work, but Java 1.6 probably works.

> Adding  server in eclipse suggests ""Apache Geronio V2.1 is currently only certified
on a 1.5 JVM. Use of any other version is not currently supported."
> --------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-501
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-501
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>    Affects Versions: 2.1.2
>         Environment: G V2.1.2, GEP V2.1.2, Eclipse Ganymede, windows XP
>            Reporter: Ashish Jain
>            Assignee: Tim McConnell
>             Fix For: 2.1.3
>
>         Attachments: NewServer3_updated.png
>
>
> While adding a server in Eclipse a message is displayed suggesting "Apache Geronio V2.1
is currently only certified on a 1.5 JVM. Use of any other version is not currently supported.".
However as we have some fixes coming into GEP 2.1.2  which makes it work with Java 6 whereas
G V2.1.2 is currently not supported on Java 6. There is a JIRA for this GERONIMO-4089 which
is still in open state. Somehow this message is misleading about the Java support of GEP/G
and users may end up using Java 5. Probably it can be modified or removed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message