geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shrey Banga" <banga.sh...@gmail.com>
Subject Re: recent console changes in trunk
Date Tue, 15 Jul 2008 14:33:20 GMT
I don't think that can be done because pluto.css is loaded after main.css
and it'll override any previous css styles for label.

On Tue, Jul 15, 2008 at 6:55 PM, Joe Bohn <joe.bohn@earthlink.net> wrote:

> YunFeng Ma wrote:
>
>> I tested the console in FireFox 2.x and IE 6.x after removing label tag in
>> pluto.css and didn't see any problem. I prefer to remove it before G v2.1.2
>> is out of the door.
>>
>
> I agree we want this fixed before we ship 2.1.2.  However, I'm not sure
> modifying pluto.css is the best way to go.  All of our style sheet changes
> for the console have typically been restricted to main.css.  I think
> pluto.css is pretty much a direct copy from pluto.  It might be easier to
> maintain if we continue to keep our changes limited to main.css.  Can you
> try fixing this by adding a new label entry in main.css without float:left?
>
> Joe
>
>
>
>
>> -- Yun Feng
>>
>> Shrey Banga wrote:
>>  > I've opened a JIRA (GERONIMO-4204) for this issue. I need to know if
>> the
>>  > float:left for labels in pluto.css is needed and where because it
>>  > affects all Admin Console portlets.
>>  >
>>  > On Mon, Jul 14, 2008 at 3:09 PM, Shrey Banga <banga.shrey@gmail.com
>>  > <mailto:banga.shrey@gmail.com>> wrote:
>>  >
>>  >     After rebuilding the server I too faced the same problem and on
>>  >     further inspection I could make out the problem was because the
>>  >     patch GERONIMO-4081 Accessibility issues (at revision: 675083) has
>>  >     surrounded text by <label> tags, which have a float:left property
>>  >     set in pluto.css which I suppose is causing the problems. I'm not
>>  >     sure why the float:left is needed in the first place but in case
>>  >     removing it isn't possible, we could create a separate css for the
>>  >     console and import it in the affected portlets.
>>  >
>>  >
>>  >     On Fri, Jul 11, 2008 at 6:50 PM, Joe Bohn <joe.bohn@earthlink.net
>>  >     <mailto:joe.bohn@earthlink.net>> wrote:
>>  >
>>  >         In addition to that quirk, there are other layout issues I'm
>>  >         seeing too (these are probably the ones Jarek was seeing).
>>  >
>>  >         For example:
>>  >         - Server Log Viewer layout is all messed up
>>  >         - All of the Applications views (WARs, EARs, etc...) have the
>>  >         layout all messed up
>>  >         - Plugin portlets layout is messed up
>>  >
>>  >
>>  >         Those are just a few that I noticed clicking on the top level
>>  >         portlet pages.  There may be other problems when you drill down
>>  >         into some of the pages to alternate jsps.
>>  >
>>  >         Joe
>>  >
>>  >
>>  >
>>  >
>>  >         Joe Bohn wrote:
>>  >
>>  >             I'm seeing strange things in trunk as well.  Using firefox
>>  >             on a tomcat image I see the following prior to the banner
>> in
>>  >             the console.  I don't see this in safari:
>>  >
>>  >
>>  >             Skip to navigation
>>  >             Skip to main content
>>  >
>>  >             The access keys for this page are:
>>  >
>>  >                * ALT plus 1 skips to navigation.
>>  >                * ALT plus 2 skips to main content.
>>  >
>>  >
>>  >             The first two are links to anchors in the page.  If I
>> reload
>>  >             the page the extra content prior to the banner is no longer
>>  >             displayed and things look normal again.
>>  >
>>  >             Joe
>>  >
>>  >
>>  >
>>  >             Shiva Kumar H R wrote:
>>  >
>>  >                 I have been committing some patches in Admin Console,
>>  >                 but most of them have been local to Plan Creator
>>  >                 portlet. On the server that's built on my machine
>> (which
>>  >                 has all the commits I have done so far + trunk code as
>>  >                 on 26-Jun), the portlets that you mention (Web App
>> WARs,
>>  >                 Deploy New,  Plugins, Server Logs) seem to be working
>>  >                 fine (I tested using IE 6 & Firefox 3).
>>  >
>>  >                 I will update my trunk and do a clean build, and see if
>>  >                 I face any problems.
>>  >
>>  >                 On Thu, Jul 10, 2008 at 9:59 PM, Jarek Gawor
>>  >                 <jgawor@gmail.com <mailto:jgawor@gmail.com>
>>  >                 <mailto:jgawor@gmail.com <mailto:jgawor@gmail.com>>>
>> wrote:
>>  >
>>  >                    Hi,
>>  >
>>  >                    I just built the latest code tried to use the admin
>>  >                 console and the
>>  >                    layout in a few places (e.g. Web App WARs, Deploy
>>  >                 New,  Plugins,
>>  >                    Server Logs) is screwed up. I see similar layout
>>  >                 issues on Firefox
>>  >                    (2.0) and IE.
>>  >
>>  >                    It does not seem like people are checking how things
>>  >                 look in the
>>  >                    console before committing the patches...
>>  >
>>  >                    Jarek
>>  >
>>  >
>>  >
>>  >
>>  >                 --
>>  >                 Thanks,
>>  >                 Shiva
>>  >
>>  >
>>  >
>>  >
>>  >
>>  >
>>  >
>>  >     --
>>  >     Shrey Banga
>>  >     Bachelor of Technology, III year
>>  >     Department of Electrical Engineering
>>  >     Indian Institute of Technology Roorkee
>>  >
>>  >
>>  >
>>  >
>>  > --
>>  > Shrey Banga
>>  > Bachelor of Technology, III year
>>  > Department of Electrical Engineering
>>  > Indian Institute of Technology Roorkee
>>
>>
>


-- 
Shrey Banga
Bachelor of Technology, III year
Department of Electrical Engineering
Indian Institute of Technology Roorkee

Mime
View raw message