geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Bohn (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GERONIMO-4182) Artifact aliases are not honored when deploying a plugin that has a dependency on another plugin with an alias
Date Wed, 23 Jul 2008 14:23:31 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-4182?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joe Bohn updated GERONIMO-4182:
-------------------------------

    Affects Version/s:     (was: 2.1.2)
                           (was: 2.2)

removed affected versions of 2.1.2 and 2.2 .. the bug is actually corrected in these versions.

> Artifact aliases are not honored when deploying a plugin that has a dependency on another
plugin with an alias
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-4182
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4182
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: Plugins
>    Affects Versions: 2.1, 2.1.1
>            Reporter: Joe Bohn
>            Assignee: Joe Bohn
>             Fix For: 2.1.2, 2.1.x, 2.2
>
>
> Create an aliasesin the artifact aliases file (for example in a 2.2-SNAPSHOT server image):
> org.apache.geronimo.configs/jasper//car=org.apache.geronimo.configs/jasper/2.2-SNAPSHOT/car
> org.apache.geronimo.configs/jasper/2.1/car=org.apache.geronimo.configs/jasper/2.2-SNAPSHOT/car

> Attempt to install a plugin that has a dependency on one of these aliases.  For example,
attempt to install the 2.1-SNAPSHOT plugin for the jsp-examples-tomcat sample in a 2.2-SNAPSHOT
server.  The expectation is that the alias will be invoked for the jasper dependency and no
attempt will be made to install the jasper 2.1 plugin.  However, the artifact query doesn't
include the aliases and therefore we attempt to download and install the 2.1 jasper plugin
rather than utilizing the 2.2-SNAPSHOT version of the plugin.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message