geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <dwo...@apache.org>
Subject Re: Need to revert GEP back to Geronimo 2.1.x depends
Date Tue, 08 Jul 2008 12:41:08 GMT
Also, shouldn't we be creating v22 plugin/feature versions of the 
following, instead of changing the depends in the existing v21 plugins 
to use the 2.2-SNAPSHOT artifacts???
	org.apache.geronimo.runtime.v21
	org.apache.geronimo.st.v21.core
	org.apache.geronimo.st.v21.ui
	org.apache.geronimo.jee.v21.jaxbmodel
	. . .

Given the goal is to release a GEP 2.1.2 that works with the 2.1.2 
Server, we can either -
1) rollback your changes to use 2.2-SNAPSHOT depends until after we 
release a GEP 2.1.2
2) create a branches/2.1 for GEP 2.1.2 and let trunk progress towards 
adding support for the 2.2 server

Given how we do server releases, I think its time we start using 
branches and trunk the same way for the GEP and do #2 above.


-Donald


Donald Woods wrote:
> Tim, we need to remove these 2.2-SNAPSHOT depends from GEP 2.1.2, as we 
> will need to release it soon after the Server 2.1.2 release and 2.2 is 
> looking like a Sept/Oct release.  We cannot release a GEP that relies on 
> SNAPSHOT jars.
> 
> 
> -Donald
> 
> mcconne@apache.org wrote:
>> Author: mcconne
>> Date: Mon Jul  7 20:49:14 2008
>> New Revision: 674712
>>
>> URL: http://svn.apache.org/viewvc?rev=674712&view=rev
>> Log:
>> GERONIMODEVTOOLS-491 Temporary fix to allow defintion of new Geronimo 
>> servers
>>
>> Modified:
>>     
>> geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/META-INF/MANIFEST.MF

>>
>>     
>> geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/pom.xml

>>
>>
>> Modified: 
>> geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/META-INF/MANIFEST.MF

>>
>> URL: 
>> http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/META-INF/MANIFEST.MF?rev=674712&r1=674711&r2=674712&view=diff

>>
>> ============================================================================== 
>>
>> --- 
>> geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/META-INF/MANIFEST.MF

>> (original)
>> +++ 
>> geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/META-INF/MANIFEST.MF

>> Mon Jul  7 20:49:14 2008
>> @@ -5,7 +5,7 @@
>>  Bundle-Version: 2.1.2
>>  Require-Bundle: org.apache.geronimo.runtime.common;visibility:=reexport
>>  Bundle-ClassPath: lib/geronimo-common-2.2-SNAPSHOT.jar,
>> - lib/geronimo-deploy-jsr88-2.2-SNAPSHOT.jar,
>> + lib/geronimo-deploy-jsr88-2.1.1.jar,
>>   lib/geronimo-deployment-2.2-SNAPSHOT.jar,
>>   lib/geronimo-j2ee-schema-2.2-SNAPSHOT.jar,
>>   lib/geronimo-kernel-2.2-SNAPSHOT.jar,
>>
>> Modified: 
>> geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/pom.xml

>>
>> URL: 
>> http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/pom.xml?rev=674712&r1=674711&r2=674712&view=diff

>>
>> ============================================================================== 
>>
>> --- 
>> geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/pom.xml

>> (original)
>> +++ 
>> geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v21/pom.xml

>> Mon Jul  7 20:49:14 2008
>> @@ -92,7 +92,7 @@
>>                                  <artifactItem>
>>                                      
>> <groupId>org.apache.geronimo.framework</groupId>
>>                                      
>> <artifactId>geronimo-deploy-jsr88</artifactId>
>> -                                    
>> <version>${geronimoVersion}</version>
>> +                                    <version>2.1.1</version>
>>                                  </artifactItem>
>>                                  <artifactItem>
>>                                      
>> <groupId>org.apache.geronimo.framework</groupId>
>>
>>
>>

Mime
View raw message