geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Forrest" <forres...@gmail.com>
Subject Re: [Help!]G2.1.2 branch build failure saying "org.apache.geronimo.buildsupport:car-maven-plugin:maven-plugin:2.1.2" not found in any repository
Date Wed, 30 Jul 2008 22:50:11 GMT
After manually downloaded and installed car-maven-plugin from 
http://people.apache.org/repo/m2-snapshot-repository/org/apache/geronimo/buildsupport/car-maven-plugin/2.1.2-SNAPSHOT/car-maven-plugin-2.1.2-20080728.181858-6.jar

then just run "mvn install -e" with maven 2.0.9, got build successful of 
branch 2.1.2.

Anyway, thanks for your prompt reply :)

Regards, Forrest
----- Original Message ----- 
From: "Joe Bohn" <joe.bohn@earthlink.net>
To: <dev@geronimo.apache.org>
Sent: Thursday, July 31, 2008 3:15 AM
Subject: Re: [Help!]G2.1.2 branch build failure saying 
"org.apache.geronimo.buildsupport:car-maven-plugin:maven-plugin:2.1.2" not 
found in any repository


> As Jarek states, you need to run bootstrap first.  However, I really want 
> to discourage use of this branch.  As Jarek states, it is temporary and 
> "frozen" as we are preparing the release.  If you want a 2.1.* image you 
> should pull from 
> https://svn.apache.org/repos/asf/geronimo/server/branches/2.1 which is 
> currently 2.1.3-SNAPSHOT (and has just one or two changes since we 
> branched 2.1.2).
>
> A Geronimo 2.1.2 release candidate should be available later today if all 
> goes well.
>
> Joe
>
>
> Jarek Gawor wrote:
>> This is a temporary branch that will be removed once we release 2.1.2.
>> But if you really want to build this branch first execute:
>>
>> mvn install -Dstage=bootstrap
>>
>> and then:
>>
>> mvn install
>>
>> Jarek
>>
>> On Wed, Jul 30, 2008 at 11:40 AM, Forrest <forrestxm@gmail.com> wrote:
>>> After checked out 2.1.2 branch, want to build it from scratch, issue
>>> command:
>>>     mvn install -e
>>> Then the build error saying
>>> org.apache.geronimo.buildsupport:car-maven-plugin:maven-plugin:2.1.2 
>>> could
>>> not found, ask me to download and install it manually. Why?
>>>
>>> Maven version tried 2.0.9, 2.0.7, 2.0.5, all same problem. Please help!
>>> thanks!
>>>
>>> Best regards, Forrest
>>
> 


Mime
View raw message